Tado TRV firmware will not update.....

Just one TRV is stuck on 54.xx,
All other TRV’s are on 70.xxxx
Tried taking batteries out overnight, reconnect, remove TRV from house and re-add, 4 weeks later no difference... ‘forced’ firmware update via HomeKit but nothing happens....
Can Tado for d the update direct?? Driving me nuts that just this one TRV goes in 0.1 Deg steps, all the others in whole degree steps....


  • You have a Tado SRT (TRV) that adjusts in 0.1 degree steps....are you sure ?? 🤔......is it an SRT or is it a Smart Thermostat (square wall mounted).......
  • Just one SRT, but only In the app and there isn’t an option to change it......all
    The others go up in whole numbers as does the temp feedback except one SRT as it also reports temp in 0.1 steps....
  • Firmware is 54.20 which is probably the issue but it simply will not update (and yes I’ve tried all the suggested fixes), can tado please force the update ??
  • Firmware is 54.20 which is probably the issue but it simply will not update (and yes I’ve tried all the suggested fixes), can tado please force the update ??
  • Ok so someone did something as all
    Zones now go up and down in whole numbers as does the temp feedback... App update??? Still doesn’t fix the firmware version of just one SRT, why???
  • Hi @Grahammg,
    Still not sure what your saying tbh...
    Currently there are no Tado SRT'S that can be adjusted by 0.1 degrees only the Wired/Wireless Smart Thermostats and the Wireless Temperature Sensors (both are wall mounted)........?? 🤔
  • I had the same problem with some SRVs not updating. I contacted the support team by email and the update was quickly pushed across. They had to do individual pushes for each non updating SRV however . . .
  • Hi all.
    To be clear, the iOS tado app allowed just one SRT to be adjusted in 0.1 DegC steps. This is the same SRT that refuses to update firmware beyond 54.20. Of course the display on the actual SRT is in whole numbers......
    Sounds like a bug to me!
    About 3 hours after the initial query the app updated and now all SRT’s on the app are adjusted in whole numbers so one bit sorted. Now to contact Tado and see if they can force an update... just why we cannot do this simply ourselves I don’t get but hey ho.....
  • Hi @Grahammg,
    Please feel free to shoot me down but I "think" that you are confusing your IOS functionality with the actual operation of the Tado device (SRT)

    I "think" that you are seeing the 0.1 degree change setting of your Homekit.....I use Android and Alexa and the "Tado" scene in Alexa also shows the ability to alter the SRT by 0.1 degree.......which it simply can't do because.....the Tado SRT is only adjustable by full degrees.
    So it's not a "bug" it's your misunderstanding of how it actually works.
    As I said earlier.....feel free to disagree with me.....but this is what I "think" the issue is. I'm just trying to help you to rationalise your perception of the problem.
  • Nope, the TADO APP allowed me to adjust just one SRT in 0.1 DegC steps all the others in whole numbers, as there is NO setting to set this in the TADO APP it is/was a BUG..... hope that makes it clear. I can’t believe I was the only one to see this but then I have been doing this for years.... Firmware update issue aside, clearly someone fixed it as the TADO APP now controls all SRT’s in whole number steps regardless of the SRT firmware.. nothing whatsoever to do with HomeKit....
  • @Grahammg,
    So sorry if I have wasted your time regarding this issue.... Just tried to assist you.....
  • No problem at all but I really wasn’t dreaming, been like that for ages (more than a year) and interestingly
    Stopped the day I asked the question. The bug went when the app updated to the latest with the ‘all
    Rooms off’ quick buttons etc.
    Go figure but surely I can’t be the only one to have seen that issue??
    As for firmware,
    I await tado support to get back to me.
  • I don’t know much about all this but I have had a tado for about six years and I have just bought two radiator controls I fitted them and they only go up In whole degrees where my original goes up in part degree if that makes sense !! I am 76 years young but still like to keep up with these things x

  • rafm5
    rafm5 | Moderator

    Am I right saying that Tado° TRVs with hardware rev 1. are on 54.xx and rev 2. from 70.xx? Can someone confirm it?

    Also, IMHO the ability to control by 0.1°C via app / web should be remover and replaced for all controllers to 0.5 °C

  • Hi all.
    The 0.1 deg adjustment came back in the app for the same one SRT on 54.2 firmware.
    Discussing this with support they said that 54.2 was the highest version for that SRT due to serial number. Personally I think that is rubbish as other systems with serial numbers younger (in some cases way younger) and some in the same range a few digits different are ALL on 79.xx.
    I can only assume that whatever hardware they used (seems for a very short period) has a different firmware..... if I could post screenshots to prove I’m not going mad I would.... tado say there are no differences in operating between this SRT and the others at 79.xx......
    I say so why is it different.....
    Oh and I read somewhere that the SRT’s don’t modulate, my ones seem to, you can hear the motor move a little bit up and down, and when ‘off’ time hits you can hear the motors travel a LOT further. Tado said they didn’t at the time, anyone confirm they do now! Mine seem to and in line with the 1-2-3 bar heat icons.....