Ideal Combi Logic+ 24 Wired Thermostat OpenTherm Installation

Good Morning guys,

I have a wired thermostat connected to an Ideal Combi Logic+ 24 on the relay interface and all is working fine. I am not able to make it work using the OpenTherm Interface. Moving the wires as in pictures and following the instructions to set up the OpenTherm interface (D01/HW on etc) doesn't work, the boiler is always ON.

Interestingly the boiler has a "Sensor readings" menu where I can see "Low Voltage Switch: ON" and "OpenTherm: Off". I'm wondering if there is any setting to change on the boiler side?

Does anyone have any suggestion?


Thank you!

Comments

  • @alex859 I had to wire 240v to power my extension kit.. not sure if it's the same for the wired thermostat?

    Is it powering up? Do the instructions state you need 240v connection in addition to OT?

    Please remember not to mix the OT and 240v wires!
  • Thanks @tadouser1000. The wired thermostat runs on batteries, I don't think there's a way to power it with 240V.

    Do you have the same or similar boiler? Did you have to change any settings on it?
  • @alex859 ah didn't realise it was powered by batteries

    I didn't have to change anything on my Ideal Logic C30 (not + model) although I don't think I have the same menus that you mentioned

    Is there anything in the boiler manual on how to enable OT?

    Might be worth getting in touch with Tado support to see if they can help
  • Yes, the manual shows how to connect the external device to the OT terminals, but it doesn't say anything about enabling it (I guess it should be enabled by default).

    Tado support say they don't give instructions on how to connect the wired thermostat to the boiler and advice to call a professional installer. I have someone from Ideal coming next week for another issue, I'll ask them about this.

    Did you have to install a harness to get OT in the non + model?
  • I have the same connectors as you, no harness required

    I can't remember if you need to remove the purple room stat/timer link when you use OT. Did you try removing it?


    You probably have these already but you can download the wired thermostat instructions here:

    https://www.tado.com/all-en/professional-manuals
  • Yes I tried...removing the room stat link the boiler never fires.

    Thanks, yes those are the instructions I followed.
  • Hi @alex859
    Just a heads up.....don't be too disappointed if your Ideal engineer doesn't know anything about how Tado operates......I've had 3 engineers out to my boiler (twice for annual service) over the last 18mths and none of them had even heard of Tado. I hope your engineer does, cos that makes a huge difference.
  • Hi @GrayDav4276

    You were right, he didn't know about TADO but said boiler wise the only thing to do is wiring the cables and then the thermostat should be configured to use OpenTherm :(

    I guess I'll have to give up.

  • Solution:

    I had this boiler fitted today, I already had Tado with a wireless extension. For the record the Tado took power (230v) from the boiler and we connected the two control wires from COM/NO on the wireless extension to the RT terminals in the boiler. The opentherm terminal is bridged over.

    We wasted quite a bit of time wondering why it wasn't working; it turned out the smart thermostat needed to be reconfigured.

    See

    https://www.tado.com/start/manuals/st/Extension%20Kit%20Manual%20-%20230V%20Relay%20Installations.pdf

    wiring as per page 7 and re-configuration pages 14 and 15

    see also https://www.tado.com/start/manuals/st/Wireless%20Smart%20Thermostat%20Incl.%20Programmer%20with%20Hot%20Water%20Control%20Manual.pdf

    wiring as per page 6 'Combi Boilers: Potential Free'


    Note: we did not use opentherm

  • Hi @Bmenaman

    Just looking at installing the wireless extension onto an Ideal Logic ESP1 combi

    Your comment has reassured me somewhat.

    Am I right in thinking you were able to power the tado using the “mains in” live and neutral connections on your boiler?

    Thanks in advance!
  • I know this is probably too late but have you told Tado support you want to use Opentherm? They can enable it remotely. On my ideal vogue boiler the Opentherm connection coming from the pcb had to be clipped together - is there anything similar on yours?