Problem with one radiator + strange bridge.....

No heat from one radiator....

I am having problems with one radiator and only that one.

The valve is not stuck, but despite indicating being 100% open, there comes no heat out. If I remove the Tado, the heat is comming.

I cannot see any difference visually from the other radiators.

I tried with two Tados and both works flawless on other devices...

Any ideas? Can you force a recalibration through the SW?

Bridge strange:

Even if I unplug the power to the bridge, I apparantly can see all radiators via web interface and APP.... Very strange. What is wrong?


With appreciation of feedback!

Comments

  • Is the Tado TRV hard to install i.e. does it feel like it's pressing on the valve pin even before it's fully seated? If so, perhaps the mount needs and adapter as the TRV doesn't have enogh range of calibration to fully open the valve?

    For the bridge, how long do you leave it turned off before checking the app? I've found that it can take several minutes of an internet outage before the devices show as unavailable on the app. However, if I tried to change any temp settings there is not way for it to be communicated to the TRV or Smart 'stat