Can't get replacement thermostat to work.

Hi, I'm trying to replace an existing Tado Smart Thermostat with the same model, as the original one keeps depleting batteries. I thought it would be a simple job of just removing the old one and putting the new one in the existing socket. I've done this and registered the Thermostat and the Tado app can see it in the system. However, although I can see it in the system and the temperature reading does seem to be correct, it's not turning the boiler on when required. When I press the button, the Tado display shows 4 vertical lines and and E, followed by an explanation mark. I can't find this particular error in the documentation but see attached.

I should add although this is a 'new' thermostat in that it's never been used, I've had it several years and the firmware is V20.7. Thanks for any help. Chris.

Answers

  • Rob2
    Rob2 ✭✭✭

    Is it really the same model? or do you mean the case is the same model?

    Maybe it helps when you wait until the firmware gets automatically updated, I don't know. I suspect it is an older generation not compatible with your current system.

  • GrilledCheese2
    GrilledCheese2 ✭✭✭
    @Chris61 that's an old symbol, I think it means the thermostat is unable to communicate with the bridge. Temporarily place the bridge 1m away from the thermostat and wait. If the two devices are able to communicate it may take a few hours to upgrade such old firmware.
  • Hi, thanks for the replies.

    @Rob2 I'm pretty sure they are the same model, although the boxes are different. I got the original as part of a UK Homeserve programme, although that finished earlier this year. The replacement, I got a year or so later when it was on special offer (not via Homeserve). The reason I am trying to replace it is because the original seems to getting through batteries extremely quickly (every few weeks).

    @GrilledCheese2 I thought it might be a comms type issue due to the vertical bar symbol. However, I can communicate with it in the app. Interestingly, when I first switched it on, it did display a 'download' icon, and it stayed like that overnight until I took that batteries out again. The firmware was still the same (20.7). I've moved it next to the bridge as suggested. Still the same at the moment but will leave it there until I get in touch Tado via chat when it opens again tomorrow.


    Thanks again.

  • GrayDav4276
    GrayDav4276 ✭✭✭
    @Chris61
    Are you sure that the "special offer" item is a Smart Wireless Thermostat and not a Wireless Temperature Sensor....??🤔
  • Hi @GrayDav4276 - yes, I'm pretty sure it is a thermostat. It fitted into the wall mounted socket of the original and looks identical. This is the box:

  • Chris61
    Chris61
    edited May 8

    The thing that is now really confusing is that I've disconnected the bridge (ethernet cable and power) and taken the battery out of the thermostat, yet the app still says everything is OK (connected and battery good), although it has picked up that the original thermostat is no longer in the system!

    Edit - it has now picked up that the bridge is disconnected but still reports that the replacement thermostat is present. I imagine it's due to lag, but it's a long one!

  • One thing, I've used the original bridge (although the is one with the replacement) but not removed the original thermostat from the system. Is that likely to cause any issues? Thanks.
  • Andreplusplus
    Andreplusplus ✭✭✭
    So you now have two thermostats in the app? If yes, which one is zone controller for your rooms? You may have to set that again to the new thermostat anyway.
    I assume internet network is ok, but maybe the thermostat is not paired or loses connection to the bridge intermittently?
  • Chris61
    Chris61
    edited May 8

    @Andreplusplus Hi, yes I have effectively two thermostats in the app, but only one connected. They are both in different virtual rooms, although there is only one physical socket connected to the boiler. The original is in a room called 'Heating', and a new room named 'Room 2' was automatically created when I added the 2nd thermostat. I've only one boiler so only need one thermostat.

    An added complication is that the original was installed by a UK company called 'Homeserve' and I was paying them a monthly fee. This agreement has now stopped and I think Homeserve effectively 'gave back' all their accounts to Tado, but it still shows up on my account:


    I think it might be easier if I delete everything and start again. The only issue is I'm a bit worried about breaking it completely, as I no longer have any heating. At the moment I can go back to the original setup, I just have to replace the batteries every few weeks! But I'd rather use the new thermostat if possible as that shouldn't have any battery issues.

    Thanks.

  • GrayDav4276
    GrayDav4276 ✭✭✭

    Hi @Chris61

    If you haven't already done this then I suggest that you contact tado° support to discuss your account........I say this because you didn't purchase your devices directly from tado°. They (tado) may have to reconfigure your system so that it works correctly.......plus they will definitely be able to offer you assistance in getting your current setup working properly again.

  • Thanks @GrayDav4276 I'm actually on an Internet Chat with Tado now. They haven't answered me yet (I started the chat over an hour ago), although I imagine being a Monday morning they are busier than usual) but hopefully they'll be able to help. Thanks again.

  • hugbilly
    hugbilly ✭✭

    I've had good responses from Tado support via this route: https://support-request.tado.com/#/contact?locale=en

    Hugh