Tado Internet Bridge - Cloud LED keeps blinking

Hello There,

I have bought the Tado V3+ starter kit with a lot of excitement but my excitement keeps fading day by day because of lack of support from Tado.

I'm an 1st time user of Tado, when trying to connect the Tado Internet bridge (V3+), the Cloud LED keeps blinking and unable to connect to internet.

I have tried all the troubleshooting methods mentioned by Tado support team but the issue is not yet solved after days.

I could understand that this is a very common issue with Tado IB, but could not find the right solution nor the support from Tado.

I tried the following already :

  1. Resetting the modem & IB itself
  2. Trying using different port
  3. Tried with different Ethernet cables
  4. Used the Ethernet port from Laptop & connected with IB, still no use
  5. But I did not try the option of creating a static IP as am not a techie.

Please let me know if there are other ways of solving this problem. Thanks a ton.


  • Can you try plugging it into a friend's internet router to see if it connects to the cloud service through that? The issue may be due to network ports (logical not physical) being blocked by your internet provider or a setting on your router

    Unlikely to be the cause but how are you powering the bridge? From a USB on the router or a separate power supply?

  • @davidlyall Thanks for your response.

    1. Yes, I tried it from a friend's internet / home and its the same case. The Cloud LED is blinking.
    2. I tried in both using the USB port of router as well as from the power socket in the wall. Same issue.

  • If your friend has a different router &/or ISP to you then it probably means your bridge is faulty. Some equipment settings used by ISPs can block a device from accessing the internet, but if you can't get the bridge to work at another home then it's likely to be a bridge issue.

  • @GrilledCheese2 Thank you for your response.

    I too have a feeling that this is faulty issue with the physical product.

    However I see there were so many people having this same issue. I wonder why Tado haven't created a video of the trouble shooting methods, so that not technically sound people also will get benefitted.

    Sadly I decided to return the product now. Will keep this thread updated.

  • Update : I have bought another IB in Maarktplaats and it worked like magic. So, the issue seems to be in the IB gadget.