White text on grey background (Temperature graphs in dark mode)

I'm using general dark mode on my device (Android)

With the the latest application update the inside and outside temperature display has been changed from black text to white text (on a light grey background. The text has become unreadable.

Can you change that back please ?

Edit: additional info, In normal (non dark mode) the text is black.
9 votes

Active · Last Updated


  • cleetje72
    Same here. In darkmodus not readable.
  • Eusty
    Same issue here too...
  • Janus63

    Same issue here too.

  • jacekz

    Same here.

    As much as text color changes (black>white), the chart background color (white>black/dark) does not, when switching between light/dark modes. In the end some text is barely readable, especially for those, who started Tado app in dark more day1, and do not know any better :)

    It would be great to have an option to align those two color switches, or give the user an option to ignore dark/light mode, or perhaps let the user fully customize the outcome.

  • Rob
    Rob | Admin
    edited October 2022

    The problem is known on our side and will be fixed asap if it hasn't been already. Thanks for the heads up!

    Edit: for those who do not see a dark mode yet. Still in beta, will be in available in every (updated) app soon. As in, this month. The beta is also intended for finding bugs, like the one that you guys found in this thread.

  • jacekz

    ACK. Just got an update this morning and the graphs look OK (=black text on white despite the mode chosen). TY

  • Jura4
    Item resolved in v6.69
    👍 thanks Tado⁰
  • o00batman00o
    edited November 2023


    The bug is present on current version (v7.52.0). First screenshot is in light mode, the second is in dark mode. The time and the outside temperature are not readable.

  • eezytiger

    @o00batman00o Your dark mode does not look especially dark, just the opposite. Here's dark mode (system default) on my Galaxy Tab S7+. Dark mode is equally dark on my Galaxy Note 20 Ultra. Light mode works as expected too. I'm on 7.52.0.

    Don't worry about the bizarre shape of the graph. I have been draining down, flushing and refilling the system today. 😀

  • Ok, so the bug is worth than expected. I erased all the app data, but still the same result. My phone is a POCO X3 pro running MIUI 14.0.2.
  • I solve my problem. Unchecking the app in this menu solved the issue.