Gloworm ultracom 38 cxi ebus connection

hello all, first time posting on this forum so please have patience.

I have had a tado system for about 3 years now (v3) all has been working fine. I have just changed the extension kit which is downgraded to a EK01-TC-UK-03 to enable the ebus connection, I have connected 230v supply and ebus + and - to the receiver and + and - to the ebus boiler connection, extension has been paired to bridge and is showing connected, settings have been modified in wireless room stat, but when calling for heat through the app no heat is called to the boiler. the firmware version on the extension is 42.6.

Is there something that I am missing.

Comments

  • What do you mean by ‘downgraded’?

    I doubt it’s a firmware issue. Does anything need to be bridged in the boiler? A room stat link for example.
  • what I mean by downgrades is the extension originally was a v3 now it is a v2 or so I am led to believe to enable ebus connections as the v3 did not have any. the question is the boiler will not fire up connected to tado, if the ebus wires are removed from boiler connection and a link is used between + and - the boiler fires up no problem but do not have any control, it has to be done manually at the boiler to switch the heating off.

  • I’m assuming you checked first that your boiler is compatible with Tado connected via ebus? Assuming you did, either your extension kit is faulty, or something needs to be enabled in the boiler to allow Tado to communicate with it.

    Have you looked at the boiler manual? If you download the Tado pro app you should get more information about whether everything is connected properly.
  • Checked the problem out with tado they said it was a firmware issue as it was running on 46.1 as it has now updated to 81.1 but still the same issue. there is nothing that can be changed in boiler settings and no comment from tado that the boiler is not compatible, so the question now is even though it is fully modulating boiler with ebus connection has anybody proven that it will run with tado in ebus mode. photo of circuit board below.


  • ebus connection is now sorted