Why does my Vallient Ecotec plus 837 heating flow temp only reach 50c

Does anyone know why my Vallient Ecotec boiler’s heating target flow temperature is being limited to 50c. The target flow temp for the rads is set to 75c. I have removed the 24v bridge. In installer mode within the maintenance menu the eBus target temp is 50c and there is 1 recognised controller. This is the controller I replaced when I fitted the Tado. If you put batteries back in the old thermostat, the flow temp increases to 75c but the boiler relinquishes control of the system back to the old thermostat and ignores input from the Tado. If I take the batteries out, the target flow stays at the 75c for a time but then ‘throttles’ it back to 50c again. It’s extremely frustrating. Any ideas would be gratefully received. Thanks in advance!

Best Answer

  • Skinner413
    Answer ✓
    Solved, removing the wireless module from the front of the boiler worked. Happy days!

Answers

  • How is the Tado installed? If it’s wired in via relay the max flow temp control will be done on your boiler, if it’s a digital connection you might be able to change it on the Tado pro app. It sounds like there might be an issue with keeping the old thermostat wired in though.
  • It’s wired via relay, I am going to remove the Vallient wireless module and see if that helps as it connects via eBus it’s the only place the CPU could be getting the desired flow rate from.

    Thanks