Thermostat no longer works


For 6 years my Tado system has worked without issues. It is a simple setup, just a bridge and 1 thermostat. No changes made in the setup, but suddenly the Thermostat no longer works. 

Symptoms are the following:

- Thermostat doesn't show the temperature if you press the button at the front. 

- No connection via the app on any phone.

So despite not having received an email that the battery is gone I decided to replace the batteries. What happens afterwards then is puzzling:

- Thermostat still doesn't show the temperature if you press the button at the front. 

- If can now see the Thermostat again in my app, if I choose the feature to blink the display to says 'Hi' it works fine and shows 'Hi'. So the display in itself is not broken.

- For approx.. 30 minutes I can see the Thermostat in my app but it shows a constant temperature and humidity, it is no longer adjusted. So it seems to freeze up once the new batteries were in, no longer any measurements.

- After 30 minutes I go back to no longer seeing the Thermostat at all, so basically back to square one.

I bought again fresh batteries to be sure, but still the same behavior. 

My thermostat uses firmware 54.20.

My conclusion is that either the automatic firmware upgrade has gone wrong so that the thermostat is not functioning correctly anymore, or something is broken in the thermostat which causes it to malfunction. 

Has anybody ever had this behavior? I highly appreciate the input anyone might have. Thank you in advance.


  • Pr4g
    Same here! Tried resetting everything with no fix.
  • Arjan80

    Hi Pr4g,

    Thanks for your message. At least good to know that I'm not the only one with this issue suddenly. Do you have the same firmware version? so 54.20? I'm hoping it is something which is wrong in the firmware so that it can be fixed this way...

  • Montage
    Montage ✭✭✭

    That firmware version has been out for ages, it's not new.

  • Pr4g
    edited March 2023
    I'm 144. Very early adopter.
    The sequence things went wrong exactly the same as you. Worked fine for 9 years until about 4 days ago.
    Now thermostat can connect but it's malfunctioning.
    I'm hoping it's software not hardware but my kit is old?!