Virgin Hub 5 Tado bridge issue

Hello,
My Tado bridge isn’t connecting to the internet. I’ve reset it multiple time, I’ve also factory reset the router but nothing has worked . I have a virgin hub 5 router. Please help :-)

Comments

  • Have you tried speaking to Virgin? The ethernet port on the hub needs to support 10 Mbit half-duplex connections to support the Tado bridge

    If their router can't support that then the easiest option is to purchase a small network switch that can support that connection and connect it between the router and bridge

  • Yes they have recommended the same as you. But couldn’t recommend a network switch, can you recommend one so I get the correct one please?
  • Running mine on the hub 5 for over a year with no problems, I just plugged it into a port on the hub

  • wateroakley
    wateroakley ✭✭✭
    edited October 2023

    @greg01491 You could try the TP-Link devices. E.g. https://www.amazon.co.uk/TP-Link-LS1005G-Wallmount-Ethernet-Splitter/dp/B07VWB347G/ref=psdc_430573031_t3_B07PYSNSDD?th=1

    Less than tenner, should auto-negotiate speeds with your Virgin router and the Tado device. If it doesn;t work, it should be returnable.

    Our rellie is using a Wi-Fi extender, TP-Link AC1200 (?), with an ethernet port to connect their Tado dongle to the Virgin home wifi network.

  • Exactly the same issue here, brand new Virgin Media Hub 5 and the Tado bridge won’t connect to any of the Ethernet ports, the ports are fine as two laptops connect @ 100mb but the Tado isn’t even see as a device on on the Hub 5’s admin panel 🤦‍♂️
  • I'm new to VM and having the same issue. Did you manage to get it sorted?

  • Robti
    Robti
    edited October 2023

    I wonder how mine just connected and been running fine for a year now, maybe different hub versions


  • Virgin hubs are rubbish. Set it to modem only mode and connect it to a proper router.

  • I've just had this issue. After switching from sky Internet to virgin media (UK). My tado wouldn't connect. I removed my whole tado app in the end. The above advice from wateroakley worked. I bought a tp-link 5 ports. And its up & running. Thanks