Tado version compatibility

My Tado Bridge is the first generation HomeKit one and the lights don't work and it's difficult to fault find. I now have a TRV that won't pair with it. I also have an extension kit for water heating, a wireless thermostat and another six TRVs which do work.

I think the simplest solution is to buy a v3+ starter kit which will give me a replacement bridge and TRV, but I'm not sure if this will work with earlier gear. Is there latest kit backwards compatible? And do I end up paying for geofencing?


d.

Answers

  • I've tried to raise this as a support ticket - but the response is that I'm not a Tado customer even though I've sent screenshots of all my gear.

    Has anyone else encountered this problem?

    d.

  • It appears that the Tado is registered against a secret email address that I don't have access to and not the email address I use to manage the account. Perplexing.

  • Try this to contact support:
    operatortado844a35e31252intercommailcom