Heating permanently on

Came back home yesterday to find the house baking hot. Temperature showing as 24.8 degrees even though TADO target temp set at 19.5. Geolocation set. So that wasn’t the issue. Once I’d finally worked out how to turn the heating off (why SOOoooo many app redesigns? It’s simply not intuitive.) I did both that and then the water. The boiler stayed on. In the end the only way I could get the boiler to switch off was to cut the power (to both it and the TADO controller).

Woke up this morning and turned the power back on. Boiler straight back on. Again turning heating and water off on the app did nothing. TADO temperature from the thermostat had at least dropped and hence it probably isn’t the thermostat. So I suspect the controller. Both were replaced within the last year when the last TADO thermostat had gone wrong.

Now naturally this would be a problem. More so when you consider that I returned home yesterday after two weeks away. So the heating had been on for days if not weeks. NOT impressed.

Answers

  • Update. I appeared to gain control back yesterday. Or at least for a while. Now I’m not so sure. Thermostat says 20 degrees and, to see if I’ve control, I’ve set the desired temp to 25. So normally enough of a difference to prompt a response. No action from the boiler. (Where has the comfort setting gone? You see to be able to set how closely the system follows the desired temp. Has that gone in an ‘improvement’?)

  • RiverswayRiversway
    edited November 4
    I have the same issue. Just had new combi boiler fitted previously had a tank & timer and was not sure the controller was working. Heating engineer confirmed controller stuck in the on position. Reported fault but not convinced the issue us being understood
  • Have all of your rads got smart thermostats? Could batteries be gone in a SRT? This will cause heat to be called from boiler and if other roads have normal valves they will get hot too

  • Same issue here. I use the extension kit and I thought of a communication issue between the kit and the bridge. I did reset the kit and made a new parings. Still the same problem.

    the only possible way is to switch the boiler off at night. That sucks.

    is there a phone number I can call on in the UK? The chat really sucks. Many thanks

  • additional note: I am able to switch the boiler of by disabling the Manual Control and Enabling the geo-location (luckily, there is an old phone registered in my account that always results away from home)

Sign In or Register to comment.