Heating coming on at night

Can anyone tell me why my heating comes on randomly through the night, but according to my heating graphs, no heat is called for? My boiler kicking in at least 3 times last night, so effectively wasting money heating a sleeping house.


  • Does Tado read these??
  • Knowing your setup might be useful to give you an answer
  • It all there in the question,

    "why my heating comes on randomly through the night, but according to my heating graphs, no heat is called for? My boiler kicking in at least 3 times last night,"

    Although I thought "boiler" might give it away, it's my central heating system.
  • MyTada
    edited December 2019
    Is the battery low in the TRV? I had similar issues turned on at 4.30am randomly. The low battery status may not be reported by the App.
    I would try and replace the battery first.
    I think Tado TRV may randomly call for heat when the battery is low. It is like someone turning the TRV.
  • I have the same issue. None of the tado radiator thermostats are calling for heat, but the radiators (with old trvs) get warm at night.
    @c12ble did you ever find a solution?
  • Jacopo2
    Jacopo2 ✭✭✭
    Do you have a smart thermostat and/or an extension kit?
  • GrayDav4276
    GrayDav4276 ✭✭✭
    edited February 24
    Was this resolved...
  • gary333
    gary333 ✭✭
    edited February 24

    I raised the same issue with Tado Support on Monday as mine does the same. Not had a response back yet.

    Would people mind putting what protocol they are using and boiler type so it becomes clearer if this is related to a specific setup.

    Mine is:

    • Boiler: Vaillant Ecotec Plus 938
    • Connected By: Digital - eBUS
  • Hi All,

    I had the same issue and I think I found a solution (I had three nights with no irregular behaviour since implementation). Instead of setting thermostats to off (5 degrees/ frost protection) during nights, try setting it to specific low temperatures which you won’t his, for example 10 degrees.

    My theory is during nights connection to your thermostats get lost/ weaken and when that happens, tado revert back to the last set temperature (which would be the high one you used during normal hours). In this case, the temperature will revert to 10, so heating won’t come off.

    Let me know if it worked by upvoting this post
  • I don’t think this is why. My system has been setup at 15oC overnight since installation and it still exhibits this behaviour. I noticed it come on a few times this morning.
  • It’s 2.30am local time. Just spent 45 minutes trying to work out why on earth the boiler and heating turned on. All TRVs manually off (stupid no remote access errors mean I have no choice). Restarted all 12 TRVs, the Bridge, cursed about a thousand times, but had to resort to turning off the boiler entirely as the wired thermostat simply wouldn’t click the relay over. Tried the tricks here (put the temp up, then down to a low temp), but nothing works.

    2000€ spent and countless days wasted on this system, and I can’t even trigger a simple relay switch - something my old Viessmann thermostat did reliably for 25 years. I think I’m done with tado.
  • My heating has began to turn on overnight despite TRVs being set to a lower temperature.

    Work up tonight with my boiler running full and temperatures being read by the TRVs at upwards of 29C despite the room temperatures being set to 16C.

    Only once I switched to away mode and back to home mode did the boiler stop running.

    I check the graphs but none of the rooms show they are calling for heat.
  • Jurian
    Jurian | Admin

    Thank you for opening this topic.

    At this time, there is no systemic issue with the tado system that we are aware of.

    The heating coming on at night can have a variety of reasons, some of them tado related, others related to the heating system or faulty wiring.

    I will give you some hints so you can continue with your troubleshooting:

    • Go to settings, go to rooms/devices, now go to all your Smart Radiator rooms (click on room name) and make those rooms independent. That way, these rooms will not be able to call for heating from your boiler. This is always the first step in any troubleshooting! It is important to understand that bedrooms get quite cold at night, and the smart radiators can call for heating. This is not always understood.
    • Make sure "early start" is OFF (this is a setting for your smart schedule). Early start can start too early in some cases, and we recommend you turn it OFF if that is the case.
    • Once you have set up your system in a way that only your main smart thermostat can call for heating, monitor the graphs and make sure that there are no interruptions of the connection between those devices and the bridge.
    • Move the tado bridge away from any other electronics, and do some trial/error moving of the bridge. Even a slight orientation change of the bridge can have a huge impact if you have connection issues.
    • Always try a set of fresh batteries if you are having issues with a specific smart radiator thermostat.
    • Always do a "radiator swap", swapping 2 smart radiators between radiators. Always make sure you take out the batteries when moving the device to the new radiator so it will do a new calibration.

    Heating system:

    • Turn OFF all heating via tado. And only turn ON hot water. Now monitor if your radiators get hot. If they do get hot, it is most likely a problem with the 3 port valve.
    • Wiring: Temporarily remove the tado heating devices from the wall, heating and hot water should now remain OFF (Only do this if you are confident you understand electricity, always turn OFF the electricity before opening any tado device.

    I hope these steps can help you to troubleshoot the described issues.

  • GrayDav4276
    GrayDav4276 ✭✭✭
    Hi @Jurian
    Great Post 📯
    Can I suggest that this response is added to the Tado Help/Support pages (assuming that it's not already there) this will indeed assist some users with this or similar issues.
  • cbd20
    cbd20 ✭✭
    Hi @Steve_1, I wonder if you've got a couple of different issues going on.

    Only reason I say that is, one issue seems to be your boiler firing in the night with no evidence of a request in the graphs.

    Secondly, if your radiator thermostats are reporting a large temperature increase and yet they claim not to be active - then they should be closed, and therefore that radiator should not get hot at all even if the boiler was on. So perhaps your radiator thermostats think they are closed, but aren't able to close off the valve completely?

    This doesn't explain why the boiler is firing of course, but I'm surprised that those radiators are still getting hot.

    I'm sure you already know this, but if you long press on the graphs you get a bit more detail about what has happened. Sometimes that can provide a clue as to what may be causing it.
  • beeftrader
    beeftrader ✭✭
    edited March 16

    Edit: My previous comment just got removed and requires approval, not sure why...

    I wrote that previous comment on mobile so I couldn't attach a graph - but just to show you how bad the connection is, I've attached it below. I've rotated and swapped multiple different TRVs at this radiator multiple times with others. It's only 3m away from the Bridge, with line-of-sight. There are TRVs that go through 2 thick concrete walls up to 10m away that are more reliable and don't drop connection.

    Device is only in use for around 8 weeks, all TRVs installed at the same time with the provided batteries. All show battery levels as full.

    Maybe I've just got a bunch of lemons?

  • Come to think of it - last night I specifically had HomeKit turn all heating to OFF rather than a low temperature. This was the first time I've done so while some TRVs have been offline in weeks. When I was walking around the house to turn TRVs manually off, some of the TRVs still had the human (Away) icon illuminated, meaning they'd never correctly triggered I'd come home at all. This was in rooms where I have 2 tado TRVs. I've previously done what @Steve_1 did - switch to away mode and back manually to solve this issue too, though I forgot to try it last night in my maddened, half-asleep state. Not sure if your issue stems from Bridge reliability, but I wouldn't be shocked if so.

  • cbd20
    cbd20 ✭✭
    Hi @beeftrader I've got a vague recollection I read somewhere there is also a minimum distance to the bridge, below which connectivity issues can occur.

    If you can, it might be worth trying to move the bridge further away from that radiator to test that theory, even if only temporarily.

    I've got a radiator thermostat in the same room as my bridge and it's probably just over 3 metres away and the connection is rock solid. The bridge is sat high on top of a cupboard using a long Ethernet and USB cable, as I was having connectivity issues with a radiator thermostat at the opposite end of the house.

    So if you can't get the bridge out of the room, perhaps try positioning it high up in that room if you can. Just a thought.
  • @cbd20 That might have been my own comment you're referring to :)

    Unfortunately I can't really find a Bridge position that will work unless:

    • I place it in a spot that makes no sense (like an extension cable going into the middle of a room)
    • I tear down walls
    • I spend the rest of my life "trial and erroring" a position
    • I sell my apartment and move to something smaller/tiny

    Given I had a 2-week period of near-perfect reliability across all 8 rooms and 12 TRVs, I'm struggling to work out how a router reboot could have caused connection issues to flare up again. If we were given some kind of ability to read and measure exact signal levels, we'd have some better idea of what works and what doesn't. As it currently stands, we're expected to calculate millions of permutations of location, angle, and height ourselves. Working out if it works takes days to test, and more time just spent looking at graphs. The more rooms and TRVs you have, the more frustrating this process becomes.

    Something I discovered by absolute chance today however. I have early start, window detection and anything "smart" completely switched off. I had a window open to air the room, and the temperature was dropping. Although I've set that room to heat at 15º, the boiler turned on and the room called for heat at a tado reading of 16.3º. Logic would dictate that if I've disabled window-open detection, early start, and set a room temperature of 15º, that indicates I do not want to heat the room at any other temperature threshold! I don't think tado accounts for this, or makes it clear enough anywhere that this is the expected behaviour if you've turned off all early start options. I know tado thinks they're smart by adding in logic to anticipate heating demands, but if you've got those switched off, it should respect those parameters. Even if that logic is not possible to completely disable/remove by the end-user, surely you would consider the edge-case of time of day and duration the heating was off? If I'm home for hours, and the heating's off, why on earth would I need the heating suddenly on at 2am? I think tado is trying to anticipate a bedroom going too cold overnight, maybe saw a drop in temperature somewhere, and decided it had dropped quickly enough to begin heating, even if the temperature was way above the minimum set in the time schedule. Just speculation, someone from tado would have to clarify if disabling any pre-heating options actually disables that behaviour entirely.

    Thinking that might have been the issue, I checked the graphs for all devices at the time I walked to the toilet. 2 TRVs were offline so they have no heating data, the other 10 show the temperature was at least 3-4º above my minimum of 15º (18.5-19º). The room I would've caused the most temperature difference in (bathroom) was still 2.5º above the minimum set overnight. I was only in there for 30 seconds so I can't imagine that movement triggered the boiler. I've ruled that threshold logic issue/bug out for now. For now I've set my minimum temp down to 12º instead of 15º again (I did this weeks ago), just to keep whatever "magic" tado thinks it's doing out of my house.

    The investigation continues…

  • cbd20
    cbd20 ✭✭
    @beeftrader reading about your example, with the window detection and the temperature drop. I think actually in the case you describe Tado is doing exactly as expected.

    If you had open window detection on, then the sudden drop in temperature would be detected as an open window event and Tado wouldn't turn the heating on, until the open window detection period ended, and even then only if it had dropped below your target temperature. In essence it would ignore the sudden drop. As you had open window detection turned off, it doesn't ignore it and as such it saw the sharp decrease in temperature and determined that it needed to anticipate that drop would keep going and so it turned the heating on in order to stop it dropping below your threshold.

    So actually in that case I think it's logic is sound, within the confines of what's available to it. Essentially by turning open window detection off Tado is suddenly trying to manage an unexpected temperature drop, as you've taken away its option of merely treating it as an open window event.

    I've seen similar effects after a firmware update. The devices warm up doing a firmware update, and then the resulting temperature drop as it cooled back down was seemed as an abnormal drop and so it briefly turned the heating on to stop it. Frustrating in that case as I believe it could be anticipated if they know a device warms up after a firmware update.
  • beeftrader
    beeftrader ✭✭
    edited March 18

    @cbd20 According to https://support.tado.com/en/articles/3387308-how-does-the-open-window-detection-skill-work and what I see in the app, there's no indication that disabling open-window detection has the side-effect of enabling early pre-heating, when that is also disabled everywhere. It's meant to turn heating off and stop it from turning on (when enabled), not turn the heating on, so whatever in-built logic there is here seems hidden from the user, which I find mildly irritating.

    Last night something bizarre occurred, which I'm going to try and reproduce again tonight. All my rooms have their final scheduled time block end at 23.30 and switch down to 12º. Last night, I turned all heating off a little earlier, at 23.10. I was in the living room at the time (where the smart thermostat is mounted) and heard it click the relay switch OFF. All good so far. 20 minutes later at 23.30, when my time schedule and all devices should go from OFF to 12º (still too low for any room to call for heat, they were all around 22-25º at that time), the thermostat relay switched back and turned the boiler and heating ON! I had to go back into the tado app and turn all devices on (boost), then turn them all off again, for the relay switch to flip back to an off state.

    I'm starting to consider that because I use a HomeBridge which allows HomeKit-issued commands to remain in "Automatic" mode (rather than in eternal Manual Control which is tado's default HomeKit implementation), that the Smart Thermostat is in a flipped state, or doesn't even know what state it's actually in. This is rather odd, but I'm starting to consider that tado's logic doesn't account for this, even though all I've done is the equivalent of going to each TRV and turned them to OFF manually, with my room settings set to "Until next time block".

    This doesn't explain the random turning on of the boiler at 2am the other night, but I did turn off my heating earlier that night. It seems there might be an issue with me turning heating to OFF and returning to the next time block, in combination with devices going online/offline during the night.

    The investigation continues…

  • cbd20
    cbd20 ✭✭
    @beeftrader I understand your frustration with the open window detection, however you have to remember this is not a traditional thermostat, it is a (so called) "smart" thermostat, and that is what you're paying for. You're correct in that a traditional thermostat will wait until the room drops below your target temperature before triggering heating. However a smart thermostat will try and maintain your target temperature based on the conditions it finds itself in.

    The conditions Tado sees in your scenario is an unexplained drop in temperature, and therefore it's attempting to prevent that drop from continuing. It's not "early start", as you're mid-schedule, and that has a distinct meaning as far as Tado is concerned. It is simply trying to ensure your temperature remains as you asked during that time period.

    With Open Window Detection on, you're telling the system that when I open my windows please stop the heating for X amount of time, and ignore the temperature drop. If it's cold after X amount of time has passed, by all means switch the heating on if needed.

    However, with it switched off as you have it, it is simply trying to manage the conditions - it is trying to be "smart". It is attempting to catch the drop before it undershoots your threshold. Something a traditional thermostat cannot do.

    As for the other issue you've found with HomeBridge integration - blimey, I wouldn't even know where to start with that one! Good luck!
  • beeftrader
    beeftrader ✭✭
    edited March 18

    @cbd20 I'd generally agree with you there, but after inspecting the graphs further, the logic seems to indicate this is additional logic to the handling of a "window open" event. It's possible the graphs are lying and don't indicate the actual state of the boiler (ie. it doesn't verify the relay switch position and whether your boiler is actually on or not at the Thermostat). You can see my annotated graph. Normally open-window detection occurs within 1-2 minutes of a sudden drop in temperature (when I had it enabled), but this was a 46 minute time period, with a drop of 5.9º, with 2 requests for heat that didn't cause any boiler operation. It might be that multiple requests for heat over an extended period of time need to occur to avoid false positives and turning the boiler on and off too often.

    In any case, setting my room temperature to 12º as opposed to 15º should hopefully avoid this wasteful situation, as it's much further away than any threshold values the tado devices are programmed with. We have good insulation in our homes here, you can see on the left side of the graph that my rooms don't generally go below 16.2º with no heating at all. This heating behaviour is therefore not as "smart" in my particular instance and why I'm annoyed it tried to second-guess my desired 15º minimum temperature. You can read on the German forum some other issues with tado and the German tradition of lüften (which is what I was doing at the time).

  • Thanks to Jurian for providing some ideas for positioning the internet bridge. The installation guides should be updated to explain these things. I imagine that a lot of people, like me, just connected their bridge close to the internet router and ended up having lots of problems, like me.

    I offered to be part of Tado lab's research effort to follow people installing their equipment. Unfortunately, I never got any further information from them. The internet bridge positioning problem is potentially the biggest cause of issues.

  • beeftrader
    beeftrader ✭✭
    edited April 6

    I've had my heating off for the last 2 weeks due to warmer temperatures, but the last days have been cold once again, so I turned on tado for the first time in 2 weeks... and lo-and-behold, after turning off the heating a little earlier than my usual scheduled reduced temp mode, the boiler fired up last night yet again for no apparent reason at 1.30am.

    I ended up walking around the apartment for 20 minutes half-asleep trying to get it to stop heating. See attached screenshot. 19.2º, and yet "heating" with fully opened valves to 12.0º. This room has the Smart Thermostat, plus 2 TRVs. 1 TRV was still stuck thinking I was in away mode (showed the human symbol), yet my away mode temperature is 12º anyway. The other TRV was stuck at 23º, despite previously being set to OFF. None of the 3 devices showed connection issues in the tado app. The only way to get everything to stop was to reboot the main Thermostat and 2 TRVs in this room. Nothing else (Bridge reboot, various Home/Away/OFF/temperature settings) would work.

    How can this be explained? How can the Smart Thermostat or TRV not realise it's heating 7.2º above the target temperature, when it has complete connection to the Bridge? What combination or permutation of logic could possibly make it calculate a random call for heat with such sensor data available to it? As this room as 3 tado devices, the graphs are not possible for me to individually extract data and see what exactly happened to cause a sole TRV to jump from OFF to 23º during the middle of the night (which is the only conclusion I can come up with).

    FWIW this room (living room) is the same room with the Bridge, and it has complete line-of-sight to all 3 devices. I gave up after many weeks of trying to find a reliable Bridge position for all 12 TRVs - I'm looking forward to the warmer days so I can forget about tado's reliability for a good 6 months or so...

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!