Can anyone help with my wiring please?

pritchardavid
edited December 2019 in Technical Questions
Hi there

Need some help with my wiring if anyone can help?

I have the extension kit and an Ideal Isar HE35 combi boiler. And power is on it’s own circuit from the consumer box with a spur. I have already disconnected the Thermostat in the hallway.

So cabling wise

- Consumer box to spur. (3 Core, Blue, Brown, Green/Yellow)

- Spur to Tado extension wall plate. (3 Core, Blue, Brown, Green/Yellow)

- Boiler to Programmer/Tado extension wall plate. (5 Core, Blue, Brown, Green/Yellow, Black, Grey) Grey is cut boiler end, can just see it from the outer plastic of the main cable. Tado extension end is lose and visible for the grey cable.

The neutral is connected to ‘N’ on both sides

The live is connected to ‘L’ on the Tado extension plate. And ‘L3’ on the boiler.

The earth is connected to ‘Earth’ on both sides.

Black cable is connected to ‘4’ on the Tado extension plate. And ‘L2’ on the boiler.

Manual for boiler is here if needed and you don’t mind helping.
https://www.freeboilermanuals.com/assets/pdf/ideal/203319_inst.pdf

Is this setup correct? Or do I need an additional cable plugged in or to move the black cable to another pin. Also what would be the correct relay to set on the extension box? The rads don’t seem to be requesting heat currently.

Answers

  • Maybe I'm missing something, but why do you have an extension kit with a combi? I just use the smart thermostat.
  • I could use it without a extension kit but wanted to move it and get rid of the old programmer so thought the extension kit would be better so I can use the wireless feature of the thermostat and plate it anywhere.
  • Jon_On_A_Bike
    edited December 2019

    From your boiler diagram, Tado needs to connect L1 & L2 together when switched on, so you need L1 -> Tado 1 and L2 -> Tado 4 - assuming the jumper is in the potential free setting

  • Thanks Jon.

    ’ll give that a go soon as I can. I’ll have the strip back the boiler cabling to be able to have slack on the last cable (Grey) and re terminate the others again. Hopefully this will all work, I’m surprised this cable was not in use before with the old thermostat. Then again this may explain why the hallway radiators always turned their why I turned the boiler on. (Wrong/bad cabling)