Cant get Extension kit to work with Worcester Greenstar 30i ErP boiler


Hi


The Extension Kit is saying 'Unfinished Installation' and is showing the red pause icon. It's paired, as the white led on the extension kit flashes 4 times and I can see it in the App.

The boiler engineer has connected the wiring as per Tado's instructions and attached are pics of the wires

He's powerflushing at present but will only be on site for a couple more hours and I'm getting desperate

I logged a call with Tado yesterday but they've not got back to me today with any ideas/advice hence my request for help on here.


Anything appreciated



Answers

  • when you added the Extension kit did it take you through all the step by step pages on the website where it asks what boiler you have, what current thermostats setup you have in place etc.?

    I didn't actually get to that page by adding the extension kit, but it did take me through it all when adding the smart thermostat.

    The instructions were very very good, the most simple step by step instructions I have ever seen!

    When its connected and functioning the white LED should be pulsing, like a heart beat

  • Thanks for replying.


    When trying to install the extension kit I get :

    ' Unfortunately, we do not have all necessary information about your heating system to provide you with specific installation instructions. An email with some follow up questions has been sent to you. Please answer this email and we will get back to you with specific installation instructions as soon as possible.'

    I've answered the email twice now, but aren't getting any further as Tado keep asking the same standard support questions over and over (well, twice)

    I can't see how to delete the extension kit and start again.

  • You can delete your home within the settings and start again but not sure if that will change anything.

    Do you have the thermostat and if so have you tried adding that yet?
  • Yep - thermostat in and connected - I can get it to say 'Hi' so it's connected ok


    Is it because the Extension kit say's 'No Remote Access'? It's paired as the extension led flashes 4 times. I've obviously got an internet connection. The app talks to the thermostat as I can make the display blink 'Hi'

    I just don't know where to go next

  • Hmmm, im not sure then. When I added my thermostat it told me to do it via a browser on the PC and it asked me to put in all my boiler details etc and then provided me the step by step instructions for installing the extension kit.
  • Ok - I'll try and see how to delete the extension kit and start over. I guess I put something in wrong when going through the setup options.


    Thanks :-)

  • Ok, let us know how you get on


  • Progress of sorts. The Extension Kit now says 'Connected'


    But I'm still no nearer getting heating, which is a problem as it's going to be cold tonight.


    What I'd like to do is delete the Extension Kit from my home and start again. Only I can't see how to remove it.


    Anyone?

  • @Bitterneman In the app, go to settings, Home Details then delete home.

    This means that you will need to start again from scratch and add the bridge and thermostat again. You will also need to add the extension again but as its wired up it should connect straight away.

    If you arent getting heat it could suggest that some of the wiring is wrong. Might be worth yourself just following through the instructions and check it against the work the electrician has done to see if it all matches up/change where neccesarry.

  • Ok - started again. The Thermostat and Extension kit paired. Extension Kit still says 'unfinished installation'

    Another thread on here bemoaned the lack of clear installation instructions - here? https://www.tado.com/start/manuals/st/101961_F-ST01IB01-INSTALLER_MANUAL_DIGITAL-TA-UK-03.pdf

    However, I can't get the Thermostat to go into setup mode - it stops after pressing the button for three seconds and then again for 3 seconds.

    I'm going to have to find someone who knows what they're doing because I'm clearly incapable of making this work by myself and Tado haven't contacted me with any suggestions in over 24 hours.


  • I'm giving up. I'm just going to get the installers to fit a Worcester Wave controller.


    Sorry Tado, I'm sure your system works with a Worcester boiler but without support you're an expensive waste of time and money.


    Shame.

Sign In or Register to comment.