Dual heating system problem

Hi guys,

I'm new here, and I've had a look around and can't see anything related to my problem exactly.

So I've got a dual heating system, so two thermostats. One upstairs that controls ONLY the upstairs radiators, and one downstairs, that controls ONLY the downstairs radiators. With the thermostats that were originally there, everything worked fine as it should. Since replacing them with Tado, it hasn't worked properly

I have the extension kit installed to the boiler, and as far as i'm aware everything has bee done correctly. I should also mention all my thermostats are wired and not wireless.

So my problem is as follows... When i use the Tado app or do it manually on the thermostat and i set the downstairs heating to come on, the upstairs heating will come on and not the downstairs as it should. When i do the same on the upstairs heating, nothing happens, so it doesn't even do the opposite, as in put the downstairs heating on.

I've spoken to Tado support a couple of times. Once because i was told i had to after i had installed the extension kit, so they could tune some settings i assume? Second time because it wasn't working as it should, and they did say some settings weren't correct, and now this is where i'm at with it.

Any help or suggestions appreciated!

Cheers

Answers

  • If your thermostats are definitely hard wired then the only explanation I can offer for the downstairs thermostat switching on the upstairs radiators is a problem with the wiring, not the App configuration. Did you DIY install or get a professional in?

    Also, is the App correctly switching on/off the heating of your hot water?

  • Agree with the above comment. If upstairs comes on when you set a temp on downstairs smart thermostat, your system is wired incorrectly.
    And again, if nothing happens when you set an upstairs temp it appears that smart thermostat is not wired correctly
  • Hi all, thanks for getting back to me with this. Yes i did do a self install with this, and the hot water isn't really a problem as the boiler just heats the water as and when a hot tap is switched on, so thats always worked fine anyway.

    I've since been in contact with Tado support a couple of times, sending them a few pictures that they requested, of my setup, wiring and boiler. Today he got back to me and said he's changed some settings. It appears to be working at the moment, but not been in long enough to try them in different combinations yet. Both on at same time, one on instead of other etc etc.

    So once again thanks for getting back to me, seems to have been some settings their end.

    Cheers

Sign In or Register to comment.