Home General Questions & Topics

Glow-worm Easicom 24 boiler constantly on

I've recently installed a tado thermostat, two tado TRVs and an extension kit to replace my old BDR91 thermostat. The old thermostat was wireless and talking to a BDR91 receiver, wired to the boiler.

I followed the tailored instructions sent by tado. Wiring seems correct, as confirmed by the tado support team.

My boiler, however, doesn't turn off, even though the temperature in the room where my tado thermostat is is reached.

I have a radiator with no valve and a towel rail in my bathroom which stay constantly on. I can see that the radiator icon on my boiler is constantly flashing.

The support team is being completely useless. They keep asking for pictures of the wiring and keep confirming that everything is okay and things should work as expected, but as said, my boiler never turns off, so clearly there's something wrong. They clearly have no clue.

One thing I noticed is that they asked me to connect wire A in my old receiver to terminal 1 and B to terminal 4, but in the instructions on the tado website, the pdf guide for combi boilers suggests the opposite (B to 1 and A to 4). I asked them whether that was a mistake but they said it's okay.

To be fair, I am tempted to return the whole set. I don't think it's working. Unless there's something I can tweak. Any help?

Answers

  • CatfuntCatfunt ✭✭

    The towel rail and no-valve radiator will be constantly on when any radiator calls for heat. I have exactly the same in my house, and it is normal.

    As for the wiring and boiler always on - I would first check all of the settings on my Tado app. One thing you could do is turn it to AWAY mode and see if that turns everything off. If it does, then you need to check your schedule for each radiator.

    If all else fails, bite the bullet and get an engineer in to check the system. That should cost no more than £70.

  • edited June 27

    Thanks so much for your answer. I solved the problem by calling a heating engineer who fixed the wiring within the boiler for £50. I can see that now it works as expected. For the benefit of others experiencing the same issue: there was nothing wrong with Tado. If Tado's wiring is correct but the boiler does not respond as it should, it's likely to be a problem with the wiring inside the boiler. In my case, the A and B wires, one connected to terminal 1, the other to terminal 4 were not connected at all inside the boiler (you can find out by yourself by switching the mains off and opening a front panel on the boiler). The two cables had not even been stripped, which means that the original installation was wrong (sigh!). The engineer created a bridge between terminals L and 1 in the extension kit, then inside the boiler connected just the grey cable (he left the black out) and (I think) moved a bridge on a connector. It works now.

Sign In or Register to comment.