Why do I get different humidity value in the tado app and in HomeKit?

Ursus
Ursus
edited July 2020 in Technical Questions
I have a tado smart thermostat, it is turned off now. Currently in the app I see 58% humidity but in HomeKit only 54%. The temperature looks like to be correct.

Answers

  • samd
    samd ✭✭✭

    @Ursus Hi - Cannot help you over Homekit but I can say that the tado smart thermostats I have are within 0.5 of a percentage point when measured against recently calibrated equipment.

  • I have no problem with the measured value, the problem is that I get a totally different value in the 2 apps. I assume tado is not updating it too often in direction of HomeKit, the humidity value, temperature is fine.
  • Hi I’m having the same issue.
    Did you ever get this rectified ?
  • rafm5
    rafm5 ✭✭✭

    Common issue recently, no official statement as of yet :/

  • vinsie
    vinsie
    edited January 11

    Maybe the issue isn't that the values are incorrect but that the HomeKit values are not updated as often (edit: I just realised that the OP already made this assumption too). I am running both the API plugin and the HomeKit in parallel on Homeassistant and I am seeing far less updates on the HomeKit integration than using the API. Sometimes updates are 8+ hours apart. The official documentation states that humidity is updated at least every 15 minutes or if the humidity changes by at least 5% since the last update. This does not seem to be the case with the HomeKit integration which is really annoying as it makes the humidity value unusable when using HomeKit.

    Is there anyone from Tado able to confirm what I am seeing?