Home Technical Questions

tado v1 Smart AC - Stuck on Updating Firmware

Has anyone else had trouble setting up their original model (mine came from kickstarter) model tado ac device recently?

I used mine for awhile, but eventually my apartment building installed central AC and I packed it away back in the box. Since we are having quite a hot summer, and the central ac is having trouble keeping one of the main living areas cooled, I decided to try and get the tado set back up again to use with the wall a/c that still resides in the room.

I did a factory reset, downloaded the latest app and added the device to my account again. The installation process seems to keep getting stuck at the "Updating Firmware" step. The device displays an icon to indicate it is downloading a firmware update for a few minutes, then it restarts and displays a wrench icon. Meanwhile, the app continues to show that it is waiting for a firmware update to complete and does not move forward. My latest attempt after rebooting the device from the "wrench" screen has the device and app both indicating a firmware update, with the "download" icon showing, for almost an hour with no changes.

Has anyone else seen this and found a way to finish setting up the device?

Answers

  • I hope you already got your issue solved, but when I had the same issue, I wrote to the tech support and they solved it remotely overnight. Try that.

Sign In or Register to comment.