Smart Rad Thermostat Won’t Mount

One of the four SRT’s I’ve just bought won’t mount whatever I try.

It’s definitely a problem with the actual mounting itself because I’ve tried the SRT on other mounts and it has no problem mounting. But it doesn’t matter which SRT I try, none will mount to the mounting. Sick of the word mounting now :#

Has anyone had this issue and managed to solve it.

I’ve messaged tado support but it could take weeks for them to respond.

Comments

  • samd
    samd ✭✭✭

    @c0ntax As you have clearly proved it's the body, have you tried activating the pin to ensure proper movement and is this particular body the same make/same adapter as the others?

  • @samd it's not the body, it's the mounting bracket (see picture below). This base mounting bracket must be faulty for some reason.


  • samd
    samd ✭✭✭

    @c0ntax My apologies - I made a mounting out of a molehill! I am stumped and can only hope you get a reply soon. Sorry.

  • @samd not a problem.

    I've just removed one of the successfully mounted SRT's and compared that bracket to the problem one as you can see from the picture below (the top one is the good one).

    The parts where the arrows point to are different. The bottom one, which is the faulty bracket looks like it's not been moulded properly. They all came from the same pack.

    I've sent tado support another message today so hopefully they'll reply soon.


  • Had this same issue despite the mounting being OK. There is a manual workaround. Pop a paperclip into the hole shown here and hold down until you hear the calibration mechanism come to life, then quickly mount the valve.