Multi-zone setup questions


My home has two zones.

Zone 1 - Ground Floor - one wired Danfoss wired Thermostat

Zone 2 - 1st and 2nd Floor Rooms and Bathrooms - Setup with tado wired stat and radiator stats

At the moment, Zone 2 main wired wall thermostat is in master bedroom with manual valve radiator; other rooms fitted with tado-equipped TRVs.

Q1: Somehow, radiator tado stats in other rooms upstairs know how to call for heat through the Zone 2 main stats - but what if my master bedroom is at the required temperature, but one of the other rooms with radiator stats call for heat? will that cause overheating in Master bedroom (due to the manual valve).

Q2: Planning to replace the Danfoss wired stats in Zone 1 with tado wired stat as well. How can the radiator stats upstairs know that when calling for heat, it is calling from Zone 2 valves?

Sorry, may not have explained very well. Happy to elaborate if not clear.

Best Answer

  • jw0ng02
    Answer ✓

    I think I have found the answer for myself.

    There is a "Zone Controller" in the Room/Devices Settings (only on the "full feature" Desktop version of the web portal!). So for Zone 1 and Zone 2, I can probably define which one control exactly which TRV's. I may need to initiate chat with support settings is not correct to start with (I hope not). But at least I know it should work eventually.


  • jw0ng02
    edited November 2020

    Hi, may be too lengthy for others to comment on.

    In short, I have 2 zones heating:

    In the setup above, my worry is that when, say Bedroom 1 call for heat, the system will commission wall stats in both zones to open the zone valve to get heat.

    So when kitchen dinner wall stat realise the desired temperature has reach and call stop heating, that will be quite a delay and waste energy due to its large space.

    or that’s not how it works? 🤔

  • @jw0ng02 this is the most helpful article I've found!! Why can't Tado's instruction explain that Zones can be set via the website 🙂
  • This feature is only available for the last few days. (Only last week they added viewing the zone. Now you can also change it). If/When they update the documentation it should help users resolve a lot of issues that used to require help from the helpdesk.

  • Thank God for that. I installed the wired thermostat and internet bridge. All worked fine. As soon as I registered the wireless receiver and a wireless thermostats,without installing it, it seems to have switched to wireless mode and I could not see it in the app.

    Since I have waited 3 days for Tado support to respond to my message (still waiting) I was despairing.

    How on earth is it an useful default to have a wired thermostat to connect to a wireless receiver? If I wanted that, I would not have wired it up!

    Thanks again.
  • Hi all,

    I have nearly the same issue, and also received the feedback via chat to use the full-web page to link the radiator thermostat to a zone regulator (Dutch: Zoneregelaar).

    Issue I have currently is that only one of the two smart thermostats is recognised as shown as a zone regulator. Somehow Tado does not know that both smart thermostats have a different connection to the Boiler (Itho Daalderop Base Cube Duo with a 2 zone circuits control logic.

    My setup:

    TADO Smart thermostat 1: living room - connected to the low temperature circuit request of the Boiler for the floor heating on the first floor.

    TADO Smart thermostat 2: Bathing room (2nd floor) - connected to the High temperature circuit request of the boiler. Which can provide high temp water to the radiators on the 2nd floor and attic.

    4x TADO thermostats on the radiators on the 2nd floor& Bathing room, which all 4 should be able to send a heating request only to the 2nd thermostat controlling the request for HT circuit.

    Does anyone know how to configure the TADO as such that both smart thermostats can be idendified as a seperate zone?

    I would like to avoid buying an additional wireless receiver to connect to the boiler directly, and had hoped the TADO would be able to do this (as it seems to indicate)

  • Checkeys
    edited December 2020

    I found a solution to get the 2nd thermostat shown up as a 2nd zone thermostat by going into the advanced configuration / setting menu using the manual for professional installers.

    I changed HC01 (Heating circuit 1) to HC02 (Heating circuit 2) for the 2nd thermostat.

    After this change the zone is also selectable in the web-page.