Internet Bridge lights do not work - but i can still remotely access my system

Internet Bridge Firmware 60.7. I think it is version 2. Bought it in September 2017.

None of the lights works, except for the pairing light. But the internet bridge works fine except for the Apple Home Integration. Heating and Hot water can still be controlled by the App and Alexa.

Anybody know why this would happen?

Changed the USB plug and wires but no difference.

Answers

  • Rishi
    Rishi
    edited December 2020

    Asked Tado support but they just want me to buy a new bridge - would not help me explain why this problem exists in the first place.

  • I have exactly the same problem. No lights at all on the Internet Bridge (same Firmware). The pairing does not come on either. In 'Rooms & Devices' it is shown as connected. I have tried different power supplies to no avail and I have noticed that the Extension Kit white light is on continuously instead of the slow pulsating light. But everything seems to be working. I will contact Tado in the morning.

  • I believe this is a poor firmware update but they refuse to own up to the problem and instead want you to buy new devices.
  • Rishi
    Rishi
    edited August 19

    Has anybody got any suggestions. It would be nice if the lights worked. I am now on Firmware 88.1 and still the lights do not work.

  • GrayDav4276
    GrayDav4276 ✭✭✭
    edited August 19
    @Rishi.....I may be wrong in my thoughts here......but I know that the 'older' versions of Tado hardware are not 'completely' compatible with the later issues of Firmware updates.......so I suspect that it's not actually a 'poor Firmware update' it's simply that your version of the Internet Bridge isn't capable of being 'upgraded' to the later Firmware version......and therefore to have a fully functioning Internet Bridge.......you would have to replace yours with the latest version.
    If I was you I would hassle Tado to provide a later version of your Internet Bridge........free of charge.....after all it's something that Tado has done that is causing your Internet Bridge to operate in a manner that is unsatisfactory to you.
  • I agree with you that this is a 100% Tado firmware update issue. However I have tried everything and Tado refuse to own up to their mistake. As the bridge is 4 years old they want me to buy a new one. Tado’s customer services is very poor and they simply do not care how much investment a customer puts into the product. I have over 15 Tado items in the house and am so fed up with their poor customer services.
  • @Rishi
    I completely understand your frustration with this issue.....however, I still feel that your only option is to continue to 'hassle' Tado and convince them to 'apply' some good customer service......good luck with that !!!
    I suspect that many users of Tado 'legacy' equipment have been / are currently in the same position as you are. I fully expect that this may also occur to my installation in the future.....the problem with Tado is that everything happens at a 'snail's pace' and therefore this type of issue will not occur for a long time.
    I personally feel that I have bought into the Tado system and having spent a fairly significant amount of cash on their product, I have since discovered that the 'promise' doesn't live up to the reality of their equipment and their User Interface.