Issue with Tado TRV not working

Hi,

I've been pulling my hair out trying to sort this. I have the Tado smart thermostat which works fine. I then added the Tado TRV, which was setup properly without any errors.

The issue is that if I increase temp on the TRV, it does NOT activate the boiler/heating. I have added a further 2 TRV's so 3 in total and all have the same issue, which rules out a faulty TRV.

If I increase temp on main thermostat, the system works as expected and everything heats up. This also rules out a faulty main thermostat or boiler.

I also have the ext kit if that makes any difference. Tado have confirmed my wiring is correct.

Any ideas?

Answers

  • I have spoken to tech support however the answer they gave me doesn't really make sense.

    They said on my system the smart thermostat controls 'the valve', and the ext controls the boiler. The TRV is unable to send a command to both of those things at the same time, which doesn't make sense.

    They suggested I get an engineer to change my system so the valve is 'always open'.

    Any ideas what this means?

  • Hi

    The STRV’s need to demand heat via whichever circuit is controlling the valve on the heating system. You normally set this on setup via an association with the Wall Thermostat controlling that circuit.

    Is the Wall thermostat hard-wired or wireless? Also, the version of bridge or Wall thermostat may affect how the STRV connects?

    I now have a hard-wired wall Tado thermostat on the circuit that feeds the radiators that also have Tado STRV’s fitted, when a STRV demands heat you would normally hear a ‘click’ from the Wall thermostat, this is the switch opening the valve on the circuit which in turn demands heat into that circuit from the boiler.

    My old system used to show the associated wall thermostat as the controller but I think now it has changed so you only see that on setup and then the signal is sent to the bridge and then back to the wall thermostat.

    My suggestion would be to remove a STRV device from your app and try reconnecting it again this time checking for options to associate it with your wall thermostat for the same circuit.

    I have five different circuits (Wall Thermostats) and it knows which circuit to open when a STRV demands heat and that can only be set during setup.

    Hope this helps?

Sign In or Register to comment.