Smart Radiator Thermostat doesn't upgrade

Hi,


My Smart Radiator Thermostat is still on Firmware: 54.12. The others are all on Firmware: 79.1. I've installed the Thermostat about a month ago. Reset, re-joined... No change


Is there a way to force the upgrade?

Answers

  • Hi @Maartenk,

    I think you'll find that this one SRT is an older version.....I'm sure that it's probably at the latest FW version for that SRT model.
    If you remove the SRT and check the Serial Number....if it starts VA01....then it's the older model.....the latest model is VA02
  • I have a VA000XXX on 79.1. I’ve got multiple devices that were stuck on 54.12, that now are on 75.2, and the ones previously stuck on 75.2 are now on 79.1. I’ve been unable to force a firmware upgrade on these devices, and tado support has been no help here. These were 3 Quattro Packs, so they would all be manufactured together in groups of 4 you would presume. Even if they weren’t, it doesn’t explain how the devices managed to go one version up in firmware, only once the rest went up a version too.

    I feel there’s an off-by-one error somewhere here, but I’ll only be able to confirm that when something later than 79.1 gets released.
  • If it helps I had a SRT/TRV that was stuck on an older version (not as old as yours though, think it was 75.2).

    I simply removed the device, took the batteries out and kept them out for 15 minutes or so. When I re-connected the batteries and the device I noticed it had updated the firmware in about 10 minutes of going live.

    Presumably not a guarantee, but nothing to lose by trying.

  • Thanks Gary, I’ll give it a shot. I was meaning to do it, on the German forums somebody suggested leaving them out for an hour, but just didn’t have the patience :)

    Got the batteries out now and will see how they go in a few hours.
  • I've removed the batteries more than once but without and results.

  • I managed to force one of my stubborn 2 remaining TRVs to upgrade last night. From my own memory during installation, updates are issued serially from the Bridge, so you have to avoid multiple devices coming online again at the same time. I also believe the Bridge won’t force a firmware upgrade if the current room / home has heating switched on anywhere (though I could be wrong). This avoids the situation of causing damage to the thermo/boiler should something go wrong. I’m trying again today with my final remaining stuck device while the heating is off everywhere, to try confirm my theory.
  • I've got the same issue bt so look forward to seeing how you get on with this. Thanks for your efforts.

  • That seemed to do the trick. Final TRV updated after 5-10 minutes of putting it back online. Now all 12 TRVs finally updated.

    So yeah, turn heating off, and take batteries out for at least 10 mins, then add them back one by one, listening out for the TRV to do some recalibration (or keep watching the TRV and touch it to look for the firmware downloading animation, which you can see here: https://support.tado.com/en/articles/3482292-what-do-the-symbols-on-the-smart-radiator-thermostat-user-interface-mean).
  • Great to see taking the batteries out worked :)

    When I was playing around with the app last night I noticed that there is an option within the app to update firmware. Not sure it works but here is where it is on mine:

    • Click "Settings" within iOS app
    • Click "Homekit"
    • Click the relevant product
    • Click "Update Firmware"
  • That option’s never really worked for me, I’m not sure it really does much in terms of an instant or near-instant update. In any case, it’s not visible for me any longer as I don’t have the Bridge added in HomeKit at all, so that screen is empty (it just instructs me to add the device to the Home app). In desperation last week I re-added the Bridge and all 12 TRVs to Home temporarily, essentially duplicating my config, just so I could access said update firmware button, but it made no difference. I always found it a little odd that the button is hidden in Home, and not in the Bridge or device settings.

    My best guess is that the serial updating behaviour of the Bridge just doesn’t work well with a certain number of TRVs, and the only way to reliably have them reestablish connection to the update servers via the Bridge is via an extended offline period (which is exactly what happens when you first install tado TRVs, as they’ve been sitting offline in a box for some while). It took well over 4 hours during my install to be able to use all my devices as they slowly updated - a very slow, confusing, and frustrating first-run experience.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!