Problem with Tado extension kit

Hi, I’ve recently installed a new glow worm e series boiler. I’ve had tado work well for the last few years on my previous boiler....


Before I tied it into the new boiler ( seems pretty straightforward), i wanted to confirm the two outputs from the extension kit: CH ON and HW ON. I’m switching live to the boiler to control it. Both functions have worked fine for the past 2 years.. I’ve never had a problem...

but I can’t get them to switch live with app? I’ve tried and failed. The extension kit pairs ok, gives a heartbeat ok. There’s no fault showing up on the app.. The live and neutral connections to the kit test ok. But the outputs don’t change when I switch them on via the app......Has anyone had a problem with blown outputs on the extension kit?....I suspect this is what’s happened but I would like to know if anyone else has experienced an issue like this with the their extension kit?

Answers

  • Montage
    Montage ✭✭

    I doubt it is a faulty extension kit.

    You should hear the relays in the extension kit when they issue a demand for heat.

    If you had this working before it should work. Did you change the boiler and then add the extension kit. I presume you had a Tado thermostat before that.

  • Thnks for the response...I've nothing connected to the extension kit and I've tried switching things on and off to listen for relay clicks .... nothing... so I think it has to be the kit...
  • GrilledCheese2
    GrilledCheese2 ✭✭✭
    edited March 9

    Remove the jumper from inside the extension kit. If there’s any discolouration on the metal pins give them a clean with some wire wool or sand paper. Check the orientation before removing and replace the same way round.

  • GrayDav4276
    GrayDav4276 ✭✭✭

    Hi @CorkDonal

    What do you mean....." I've nothing connected to the extension kit ".........??🤔

  • I meant that in order to hear if the relays were 'clicking' the outputs were disconnected. The kit was powered up and connected to the router and to the App was behaving normally.

  • cbd20
    cbd20 ✭✭

    @CorkDonal Have you tried forcing the relays by using the button on top of the extension kit itself, thus removing the app from the equation?

    As per this link here: https://support.tado.com/en/articles/3387246-how-can-i-control-my-heating-system-when-the-radio-link-between-the-smart-thermostat-and-the-extension-kit-is-lost

    Have you got any other Tado devices currently up and running?

  • @cbd20 , thnks, I didn't know about this....I just tried it but again... 'no clicking relays' .....Everything else works fine.. I have about 6 radiator thermostats, a smart thermostat....all OK... And the Extension kit connects to the router every time without a problem....But it just doesn't do anything..... If the relays are gone they're gone and I'll buy a new extension kit....But I'm just trying to determine that's the case before I fork out for a new one...

  • cbd20
    cbd20 ✭✭
    @CorkDonal certainly starting to sound that way.

    However, reading that link I posted again suggests the button only works when it has no connection to other devices. If you haven't already, perhaps try switching the bridge off to force a disconnect, then try the button again? That way the extension kit is definitely isolated from the rest of the tado system.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!