Extension kit with Glow-worm Ultracom 30CXi

Extension Kit eBUS mode & Glow-worm Ultracom 30CXi - all help greatly appreciated!

I've had the Tado system working with the Wireless Receiver for a short while but wanted to take full advantage of the boilers modulating capabilities which means having it connected via eBUS rather than relay. As such, I did some research, bought the Extension Kit and wired it in today.

For eBUS the boiler apparently requires 0v and 24v to be bridged -as shown in attached pic. The Extension Kit has paired successfully and shows up in the App. The boiler knows there's an external controller connected as it shows "Ext" on its display. I've changed all the Tado devices to request heat from the new box.

Programming the new Extension Kit as an eBUS controller from the Wireless Thermostat (as shown in the pic) fails every time, and I've tried over and over. Despite multiple Tado TRVs calling for heat the box simply refuses to play ball.

I've had to give up for the day and swap the wiring over to relay mode. This has got the heating up and running which at least proves the box is working. Really hoping that somebody can shed some light on the problem. :-)

Best Answer

  • Chris_L
    Answer ✓

    Pretty sure I've got it sorted!

    The solution was to pretend I was swapping out a compatible Glow-worm eBUS controller (in this case a Climapro1 RF) and run through the installation sequence in the App which successfully programmed the Extension Kit.

    I still have no idea why it won't accept eBUS mode programming from the engineers menu on the Wireless Thermostat, but at least it's job done! :-)


  • Still no joy getting eBUS to work. The Extension Kit simply refuses to save Vaillant/Glow-worm eBUS settings (D07 - or D05 for that matter), showing FAIL at the end of the setup process.

    My Glow-worm Ultracom 30CXi has eBUS connections. The Extension Kit (firmware version 81.1) is supposed to support Vaillant/Glow-worm eBUS. All the wiring (AFAIK) is correct, including the 0v/24v bridge. I'm in the UK, so there aren't any Opentherm modules - it's a straightforward 2-wire (plus and minus) connection directly from the boiler to the Extension Kit.

    Anyone have any thoughts as to what's wrong?