Heating not working on 2 zones & classed as 1 zone.

I have just installed my Tado this morning but it is not working as expected.

I have the hot water extension kit & 2 Thermostats. 1 upstairs and 1 downstairs, however when ever I turn heating on downstairs, upstairs come on too. Why would this be?

The Tado walk through set them both up as wireless thermostats, I think this has something to do with it.

Any advise/suggestions would be great.

Thanks

Answers

  • Klaus_Ludwig
    Klaus_Ludwig ✭✭
    edited March 20

    Option 1:- When you say that you have two thermostats are you referring to SRT's (Smart Radiator Thermostats)? If that is the case you will only have control of two radiators if they are radiator mounted. They need to be allocated non identical room names. It is worth exploring "Rooms & Devices" on the app to see and change the control structure to your preference.

    Option 2:- If you have most of your radiators fitted with SRT's and the two thermostats you refer to are the square ones then you can control each room individually using the SRT's (rather than just upstairs and downstairs) and could set the square thermostats in "rooms & Devices" as the "Measuring Device" for each of the two rooms where you prefer the most accurate control.

    Option 3 (least likely):- If you have done the very unusual and somehow successfully rigged and calibrated SRT's on two central heating zone valves (upstairs and downstairs) and they are not mounted on radiators then you need to set the two square thermostats as the measuring devices for upstairs and downstairs and ensure that the two SRT's are given different room names to exactly match the two room names of the two square thermostats.