Siri defaults to “cool” mode

Hi there guys,
I have a Tado Smart AC Control firmware 59.5 and iOS 14.7.1 controlling a Daikin Zena split aircon.

Everything works ok, except when I use Siri to turn on my heatpump.

If I say “Hey Siri, heat up the kitchen to 25 degrees”, it turns the heatpump on in the “cold” mode, despite Siri responding “ok, heating to 25 degrees”. So there’s been a few occasions where I’ve turned up expecting a warm house only to find a unit blowing cool air.

If I say “hey Siri, set the heatpump to heat”, it changes the mode to heating ok.

The issue is that I have lost confidence that Siri will set the unit to the correct mode when I ask it to turn on the heatpump. The “auto” AC mode would fix it, but this isn’t offered through the Tado app for my unit.

I’ve created a scene with the correct mode, and can do it that way, but I was just wondering if anyone has found a workaround to set the Siri default mode to heat rather than cool, or even better, to pick the mode to use based on the temperature in the room, and choose the mode accordingly.

Thanks in advance,

Mike