Radiator thermostat letting heat through when set to off

One of my smart radiator thermostats has been causing a bit of an issue, where even when it is set to off, if the boiler is on (i.e. set to heat another room) some heat is still getting through to the 'off' radiator.

I don't think it's a calibration issue, as I've tried re-calibrating and also tried using one of my other smart radiator thermostats and the issue persists. This leads me to think its something going on with the radiator itself.

I've no idea where to start though as my radiator knowledge is next to zero (I'm amazed I was able to set this system up to be honest). So before I spend money on plumbers, has anyone else had this issue? Or does anyone think it may be something simple like 'tighten x up on the radiator'?

Thanks in advance.

AD

Answers

  • You may have deposits of limescale or other debris on the seat of the valve which is preventing the valve from fully closing. You can try and shift the muck by repeatedly opening and closing the valve but you may have no option but to replace it.

    Another possibility is a sticky pin which is stopping the TRV head from fully opening and closing the valve. Remove the head and use the side of a flat blade screwdriver to push the pin down. It should move smoothly and spring back up when the screwdriver is taken away. If the pin is sticking you may be able to loosen it with a spray of wd40.

    Unfortunately TRV valves do not last forever and will need replacing from time to time.

  • @AndrewD The suggestion by grilledCheese is right but not the only possible root cause in my experience. I have the same occasionally with the the Tado radiator valves after using them for over a year now. Occasionally they don't work properly and a radiator is hot even though it is set to off. The first approach I try is to pop the batteries out and that usually works. What I have had to do on 2 occasions was to delete the TRV from the room and add it back in. That also did the trick.

    Hope that can help but it could also be a stuck valve as @grilled has said.

  • Thank you @GrilledCheese and @PDP for those responses! I have tried removing the battery a few times but doesn’t seem to help (it does its recalibration and then back to how it was). Will investigate the valve and contact support in case they can help too.
Sign In or Register to comment.