Unable to add Tado Smart AC to Tado app after removing from HomeKit

Initially I added the Tado Smart AC to my Apple Home app, but it would only setup in thermostat mode. Which is not what I want.

So I thought I would add it to the Tado app to see what other options I have but it won’t let me. I’ve removed from the Apple Home app, but if I try to add to Tado it tells me that the device is already registered in another home.


  • Got the same issue too, could anyone help? Great thanks!

  • I literally have the exact same issue, set up originally in Home app, can only turn off and on and set it to a desired room temp for it to reach. I keep going to work and finding my AC has turned itself on without my knowledge causing unecessary electric consumption.

    Ive removed it from the Home app, tried with Tado app, factory reset the AC control panel, same issue, tried repairing with Home app and it lets me but tells me a setup is needed.
  • @LRA if you have reset the Smart AC, you need to perform a setup via de Tado app again. Otherwise how does the Smart AC device know what airco brand/model you have?

    If the app says it is registered to another home you need to contact Tado. Only they can remove/change the home registration in their Tado systems.

    Thermostat mode has been removed. So a new install will be in standard mode I think.