Smart AC (2x) and Homekit “not responding” issue.

I have an issue with my 2 (two) Smart ACs. They continuously go to the “not responding state” in Homekit. They are still reachable and usable in the Tado app itself at that moment though.

What works for me consistently as a workaround, is blocking internet access of any ONE, or BOTH Tado Smart ACs in my wifi router. When I do that the “not responding” state does not happen at all in the Homekit app on the Iphone, iPad or Apple TV4K. Of course you cannot use the Tado app after a short while, with internet access blocked for the Smart ACs. But homekit works fine then.

What also works is removing any one of my Smart ACs from power. Then the “not responding state” does not occur for the remaining Smart AC.

Tado helpdesk says it is probably an issue with iOS 15.2. And recommends upgrading to a new beta release, but failed to mention whether this worked for support themselves. After I tried iOS 15.3 beta the issue remained. I am not sure why Tado specifically mentions iOS, the iPad uses iPadOs, the Apple TV 4K uses TvOS, and the Homepod uses HomepodOS.

I have my doubts whether this is iOS related, it seems more like a possible software issue in the Smart ACs that impairs homekit communication when two Smart ACs are connected at the same time to the Tado cloud. Maybe a connection “hangs” sometimes when multiple Tado devices connect to the Tado cloud on a single account, and prevents further network sessions. I see in Discovery DNS-SD app there is no _hap._tcp traffic from the Tado device when it is in “not responding” state.

But I might be wrong, maybe it is a network routing issue or indeed a Homekit issue. But my devices from Eve, Hue and Nanoleaf have no issues at all in Homekit.

Comments

  • rafm5
    rafm5 ✭✭✭

    Just FYI - iOS 15.3 beta 2 (released yesterday) does not resolve 'device not responding' issue.

    Also the lag in transferring data to Apple Home App / from tado° still exists, so customers will get contradicted temperature / humidity readings.

  • I only have a Tado V3+ and "not responding" is the usual status for this buggy accessory. I have more than 40 accesories at home (Lifx, Aqara, Nanoleaf, Ikea, Yeelight...) with no problems but Tado is a disaster. Restart device or router, change the router preferences, etc. It only gives me an hour of normal operation.

    Tado should start working on its software, because I don't think it's Apple's fault, it's this poorly made machine and/or software.

    I am already looking forward to replacing it with another similar product that works as expected.

  • @Jose7 does blocking the internet access for your Tado device result in stable homekit connection, like it did for me?


    I have been looking at my Asus wifi router log. Both Smart ACs break their wifi connection and disassociate, between 1500 and 2500 times a day. And reconnects to wifi immediately again after the disconnect.

    Interestingly the wifi disassociating stops when I allow internet access for the Smart ACs. It seems whenever the internet connection is blocked (or in any way not present) the Smart AC responds by continuously stopping and starting the wifi connection. My router can handle this but if a lot of devices would do this it would perhaps have an impact on overall wifi performance.

  • In the Reddit thread “Anyone else have issues with their Tado HomeKit accessories after 15.2?” by missbootleg there are more posters having the same issue as mine.

    “No response” issues in Homekit for them do not happen when blocking internet access for the Tado devices,  but then there are soon issues with i.e. a Velop wifi router crashing after some time when restricting internet access.

    I have an Asus rt-ax86 (non Homekit)router plus two AImesh nodes, and my router seems to be able to cope with the spamming of wifi disassociations. The Velop seems not to like that. In any case it is a very unsophisticated way to check/repair internet connections.

    What I also noticed when I upgraded my Asus a few days ago I had to power on/off the router after the upgrade. After the reboot all my devices reconnected to wifi with no issues, only the Tado Smart AC needed to be powercycled to reconnect to wifi. Seemingly although it stop/starts wifi many times when no internet is available, it has difficulty to get a new wifi connection without help.

    My feeling is that the network part of the Smart AC is simply not very stable. Mainly when connected to the Tado cloud.

    Earlier I said that if I only block ONE of my Smart ACs the “no response” in HomeKit does not happen. That is not true it seems, I still get “no response” but much less frequent and it sometimes resolves itself.

    This morning Firmware version 95 was pushed by Tado to my Smart ACs without any action by me (came from v94) as also mentioned in the Reddit thread. Homekit issues came back after some time. Even after a powercycle of my Smart ACs, Apple TV4k, HomePod, iPad and iPhone. I only need to reboot my wifi router later to see what happens then. I could also try to hard reset my Smart ACs but I am reluctant to do that. 

    So I am probably back to blocking internet access for the Smart ACs.

  • Where do you see a firmware v95? My thermostats are running von firmware 54.20 and my bridge on 92.1.
  • It is the firmware for the Tado Smart AC. It is on a different version than other Tado products.

  • UPDATE: I have found something else while looking at my Asus router log. My Netatmo v2 weather station (non-homekit version) also disassociates every five minutes or so and reconnects. Then I remembered an article about explaining why my Netatmo v2 could not use homekit but later models could, and I found the article.

    Netatmo quote “We have also had to make changes to the Weather Station’s circuit board. The Stations connect to Wi-Fi at regular intervals to communicate their data to our servers. However, the HomeKit protocol requires a constant Wi-Fi connection. After carrying out tests, we realised that this constant connection was causing the circuit board to heat up which could distort the Station’s internal measurements. Due to the design of the circuit board at that time we were therefore unable to provide accurate internal measurements. We have therefore modified the implementation of the components on the circuit board to move the temperature and humidity sensor away from the Wi-Fi chip in order to limit the impact of the heat on the measurements.

    For the Netatmo v2 is explains why it disconnects. But for the Tado smart AC it would be bad. Netatmo states an continous connection with wifi is needed (I think it is true HomeKit needs a continuous connection, you don’t want delays because the device has no connection to the homekithub. So if there is no internet connection i.e. it is blocked or if the Tado cloud account does not respond in time, the Smart AC resets the wifi connection which is not nice for HomeKit. Strangely enough it works for me with blocking internet still most of the time. Only a delay would happen when the Smart AC is in the proces of disassociating, reconnecting and DHCP negotiations.

    But it would be surely nice to be able to tell Tado Smart AC that I do not use Tado cloud and want HomeKit only, and thus it would stop disconnecting wifi. Tado should at least find a better way to check internet connections, especially for those users who want to use homekit, but blocking their internet connection crashes their wifi router seemingly because of continuous wifi disassociations.

    For me it is most likely a bad networkstack on the firmware of the Tado Smart AC. Based on the info I have now, I say sometimes the Tado cloud does not respond soon enough for whatever reason. And this triggers a bug that prevents any more Homekit traffic sessions initiated, but still allows Tado cloud trafic.

    Also Tado @Jurian confirms there are Tado cloud issues. In https://community.tado.com/en-gb/discussion/4783/launch-a-range-extender-or-upgrade-to-mesh-network/p2 Jurian states:

    “Improve the reliability of the connection to the cloud from the tado bridge (making sure the bridge does not lose connection unless there is a real internet outage, which is very rare).” 

    “I linked to the other thread, to let everyone know that we will NOT be developing a local schedule, instead we will look at significantly increasing the stability of the connections from the tado bridge to the tado devices and from the tado bridge to the cloud.”

    Please note: This firmware has not done anything for the stability of the connection to the tado cloud (the LAN connection).”

    I think firmware v95 if anything has made it worse. My feeling is that homekit has become less stable. It takes sometimes a few seconds for the Smart AC to reconnect and even other devices seem to be affected by it. It still works but is closer to breaking now.

    Btw, I use static IP addresses for all my devices.