Update the app so it works properly with iPhone 14 pro camera….

JimH
JimH ✭✭
edited October 2022 in General Questions & Topics

….as it is there’s a focus point around arms length but it’s almost impossible to keep the resulting tiny image still enough….

I suspect a different lens or maybe macro mode needs to be selected by the app for this new phone?

«1

Comments

  • Are you sure you need a camera for the Tado app? Can’t think why you would
  • Yes - for scanning QR codes to register devices!….
  • That makes it a phone problem and not a tado° problem.......

  • No it doesn't - the Tado app needs updating to recognise and use the new camera in the new iPhones properly - it's not a great app experience for new Tado users otherwise!

  • GrayDav4276
    GrayDav4276 ✭✭✭
    edited October 2022

    @JimH

    I bow to your experience in this area........I personally use Android and have not experienced this problem.

  • @JimH is the problem still present? I think that there has recently been an iOS release targeting exactly this problem https://www.gsmarena.com/apple_says_that_a_fix_for_iphone_14_pro_max_camera_shaking_is_coming_next_week-news-55859.php. If the problem persists please contact our support team. I have too few details escalate the problem from the forum.

  • JimH
    JimH ✭✭
    edited October 2022

    HI - the problem still exists - it's not an iPhone 14 Pro camera issue. Can only really be demonstrated with an example of this new device and the Tado app.

    The new camera needs to switch to be switched to macro mode (probably in software - I'm not a developer) to enable proper/easy focus on a Tado QR code within the square camera area provided in the app (see attachment 1).

    The current focus point with this device in the app is so far away (see attachment 2) it's almost impossible to capture the QR code.

    It's not an issue with the iPhone 14 Pro camera as it focuses just fine using the iOS camera app (attachment 3) - you can see that the "Macro Mode" icon has automatically switched on at this focus distance.




  • Have the same issue.

  • @JimH thanks a lot for the screenshots. I warned the support team about the fact that this topic could be around. I would appreciate if you could open a ticket on it and send also some details like the app version you are using so that our developers can try reproducing the bug.

  • Joey
    Joey | Admin

    @JimH @Charliegn52

    Are you using the Beta version of our tado° app or the regular production version, and if so, please confirm that you have updated to the latest version.

  • JimH
    JimH ✭✭
    edited October 2022
    Hi - recently (last day or two) updated to production app version 7.1 (12688) with dark mode and iOS 16.1 (iPhone 14 Pro) and the issue still persists….
  • GrayDav4276
    GrayDav4276 ✭✭✭
    edited October 2022

    Post removed.............

  • New user a few days back, on iPhone 14 pro with the same problem on standard software, I thought it was because of the film for sticking the codes ,so ended up manually adding my devices
  • @Joey yep, iPhone 14 pro
  • Despite todays update, App still does not work to read QR COde with iphone 14 Pro Max :(

  • Ich habe mir heute eine Bridge und 8 Thermostate gekauft und wollte diese einrichten.


    1. Mein Iphone 14 Pro bekommt die BarCodes nicht gescannt ! Total Dunkel und unscharf.
    2. Der Thermostat der bei der Bridge dabei lag veriegelt nicht beim drehen fällt er immer wieder ab.

    Ich hab soviel Geld dafür bezahlt und alles Schrott, nicht nur das ich noch ein extra Adapter 30,5 für Vailant brauche sondern das hier schon beim ersten Thermostaten nichts geht.

    Ich schicke den scheiss zurück und hole mir doch das Bosch Smart Home V2, hab genug von Tado 5 Stunden verschenkt !


    Ich schick den scheiss zurück und hol mir doch Bisch

  • Nun habe ich den Thermostaten nochmal zurück gesetzt nun meldet er Fehler E2 Nach erneuerter De und Montage kommt nun Batterie bitte austauschen, nach nicht mal 4 Stunden !!!!!! Eben neu ausgepackt und Batteriefähnchen entfernt !

  • @Chris_Cygnus

    Your last two posts have ended up in the British forum.......sorry.

  • Nov14 - no fix in sight!
  • still no fix tado - can you sort for iPhone 14?

  • Problem still exists… really bad Tado didn’t fix this already! Why should this take a half year to fix @Manuel @Joey!?
  • Montage
    Montage ✭✭✭

    You can wait half a decade around here.

  • I have had the same problem very disappointing how Tado are so slow recognising and fixing problems
  • Hi tado admins - I just found this (3 month old;) issue and wonder whether there is any update re. when this issue will be fixed in Tado app for iPhone ?

    Currently using latest verion (7.14(13002)) on iPhone 14 pro and attempting thermostat device registration with camera. Unfortunately this is not working yet: image is only in-focus/sharp when holding thermostat device too far from phone. But then app still doesn't recognise QR code. :(

  • Have tado° not sorted this issue yet..........wow, I can't say I'm surprised tbh

  • Hi everyone. Just installed the app on my iPhone and tried to scan first device. Camera doesn’t properly load, although I have granted permissions. I’m just left with a white screen in the app and no vision from the camera.

    It sounds like slightly different issue to what is being discussed here, but is my experience a known issue too?

    Thanks for any help!
  • GrayDav4276
    GrayDav4276 ✭✭✭
    edited February 2023

    @Joey @Manuel

    Is tado° actually doing anything about this for the iPhone 14 Pro users.....??🤔

    More to the point......are any tado° employees checking into the Community Forum to see what's happening to/with your customers.....you all seem to be conspicuous by your absence.

  • Guanaco
    Guanaco
    edited March 2023

    Hello,

    I also have this problem on my iPhone 12 Pro Max. The problem is linked to all iOS 16 device that can use the new feature "Desk view".

    I'm a frontend developper and we had exactly the same trouble on our app where we also need to scan a QR code.


    What's happening ?

    Simple answer: The app request the list of available camera.

    Before iOS 16, the result was something like ['front camera', 'back camera'] and the last in the list was taken so 'back camera'.

    From iOS16, the result was something like ['front camera', 'back camera', 'zoom back camera', 'wide back camera', 'desk view'] and the last in the list is also taken so 'desk view'. The problem is here...


    Technical answer: I figured out that the @zxing/ngx-scanner library is used in the Tado app for decode QR code (the same that I use (there is not a lot of QR decoder library for angular)). But this library take also the last MediaDeviceInfo in the list so 'desk view'. You can find a lot of issues opened for this bug on the GitHub page of the library. Unfortunately the library is no more actively maintained. I found a way to fix this problem by passing the good MediaDeviceInfo to the QR code scanner. If needed I can be in touch with a dev of yours to help 😉

  • At last a technical answer to the problem! Let's all hope that TADO take note - it's been an issue for far too long...

  • Agreed. Lack of Tado confirmation and action is very disappointing.

    I've spend bought approx dozen of their products, but activation is a overly onerous and time consuming for iphone users.

    Hence have pointed friends interested in this type of products already to potential alternatives. This issue being one consideration, but more so the general lack of Tado communication (around this issue, but also thread/matter support which could be key in bigger homes, etc).