Fix bug where manual timer for heating changes does not work

Options
Expected behaviour:
GIVEN a room has a timer set for ‘Manual control on Tado device’ under settings/rooms and devices
AND the room is currently running its standard schedule (ie there is not a manual adjustment currently running)
WHEN the user makes a manual adjustment to the temperature for that room
THEN the manual adjustment meant expires after the time set in ‘Manual control on Tado device’/‘Timer’
AND the room temperature is set back to the scheduled temperature

Actual behaviour:
WHEN the user makes a manual adjustment to the temperature for that room the manual adjustment does not expire, it uses the ‘Next automatic change’ time

For a user this is particularly frustrating when using Alexa to make a change. If I want the bedroom to be a bit warmer when I’m in bed and use the Alexa to increase the temp, it often stays on late into the night and I wake up really hot in the early hours to have to manually resume the schedule. This happens both when the manual change is started from the app or via Alexa

I have a screen record of the bug in action on the app if you need to see how to recreate it
2
2 votes

Active · Last Updated

Comments

  • Jarv
    Options
    Thanks for the response Gray, what are the two methods? The room setting and the slider bar on the manual adjustment screen? If this is what you what you are referring to I do use both methods, but the Room setting should be the master setting for this
  • Jpa
    Jpa
    Options

    I have the same problem, in my case my heating is switched off, I set a room to be on by setting the temperature and then setting the timer slide to 1 hr. The heating (in that room, as its on a smart radiator thermostat) does not turn off after the 1hr. Any ideas?