Small bug in heating activity graph

There is currently a bug in the activity graph after a temperature target is changed via Homekit (in this case specifically Siri). The activity graph fails to show the correct categorisation after the system reverts to the current schedule (its set to revert any manual changes), or an away state.

The following screenshots attempt to explain what I mean:

Above shows that the command to Siri to increase the upstairs temp to 21 at around 10am worked as intended - the target temperature is set to 21 and the mode is correctly set to "manual".

Above shows that it correctly detected that I had briefly left the house and thus the "away" state was activated, but incorrectly shows as "manual".

Above further shows that later on in the evening the default schedule has in fact resumed and the temperature is now set to 10. The slight bump before the period highlighted is the heating downstairs coming on as people come home from work.

Notice that for all these transitions the activity log is still showing a manual temperature setting. At no time after the initial 10 am Siri command was anything changed manually in Homekit or the Tado app. If it makes any difference my Tado system is an older one that has been grandfathered in to free automations - we I have all the packages available.

Also note that I have worked around another Homekit integration bug: the light blue sections in the graphs above are periods that in our default Tado schedule that we want the system "off", however I have not set them as actually "off" in the Tado app, but 5 degrees (which is effectively off). This allows me to ask Siri to set a temperature - unfortunately if the Tado system is "off" asking Siri to change the temperature fails as you first have to ask Siri to turn it on...

1
1 votes

Active · Last Updated