Home Suggestions, Ideas and Improvements

[Released – ver. 5.10] Manual Control of Home and Away mode

12345679»

Comments

  • @robotive Initially it asked me for my AppleID and password, then nothing - it just seems to minimise off the bottom of the screen and return to the V3 main menu every time.
  • Adrian (tado°)Adrian (tado°) | Developer
    @siber0 That is strange… Could you please submit a support request and send me the ticket number so that I can have a look? Thanks.
  • edited March 2

    Hi @robotive : looking at the overall usability of the app it would be a good thing to have the possibility to add this button also directly to the homescreen of the Tado app. The less manipulations you have to do to get where you want, the better.

    unlock phone - click tado - click geofencing - click away

    versus

    unlock - tado - away.

    It might be a small thing but it would make it more user friendly.

    thanks for the update

  • Adrian (tado°)Adrian (tado°) | Developer

    @MaartenSomers Hi, will forward your feedback to our Design team, thanks!

  • VertigoVertigo ✭✭✭

    Will this be exposed through the API for home assistant (and similar) users? I havent touched the tado app in 4 months and dont want to start having to.

  • samdsamd ✭✭✭

    @robotive Many thanks for your input. When you turn off 'Include devices location' it automatically assumes you have left home and prompts for Away mode. I was hoping not to use anything other than the manual switch and close down any phone overheads.

  • samdsamd ✭✭✭

    @robotive - Now sorted following need to re-sign on.

  • Adrian (tado°)Adrian (tado°) | Developer
    @samd Why did you had to re-signin? Was there any issues with the beta or something else?
  • samdsamd ✭✭✭

    @Adrian (tado°) No idea really, just tried to load the app and it asked me to register/sign on.

  • Adrian (tado°)Adrian (tado°) | Developer

    @samd If you happen to have a few free minutes, could you please submit a Support ticket and send me the number so I can get in contact with you about this? Thanks.

  • samdsamd ✭✭✭

    @Adrian (tado°) No problem - will do.

  • samdsamd ✭✭✭

    @Adrian (tado°) Support ticket is ID 1116541

  • jcwackyjcwacky ✭✭✭
    edited March 9

    @adrian142 My wife and I also had to sign into the app again. I installed the beta, but my wife did not.

  • samdsamd ✭✭✭

    @jcwacky Hi - Adrian is taking analytics from my app - I have had to sign back in 3 times now since beta. If Adrian finds anything I'm sure he will post it here - if not I will.

  • samdsamd ✭✭✭

    Support have spotted the issue that causes 'sign-outs' and are working on it

  • @Adrian (tado°) thank you for this! You just saved the Tado set-up in my home. I was thinking for some time now about returning my whole set-up (1 room thermostat + 6 radiator thermostats) due to the lack of this option. Instead now I bought 2 more radiator thermostats!

    Great to see you do listen to customer ideas. At first I lost hope when I saw this topic (so many requests, so little response). Good thing I had a final look before making up my mind. I do agree communication could be better, but for now I'm happy. Thanks again!

  • Is this likely to be rolled out soon or is it only in beta form.

  • Is there a description how this feature will be implemented?

    I've read all kinds of idea's, and am curious what it will be.

    This is a must-have for me, and now am in the 14-days money back period, so I need to know what it will be, because a heating schedule is nice, but I've learnt the past years that I use the 'override, now set it to 18 degrees till I give you a new command' so often, that it's not nice to have to edit all 7 rooms when we leave the house.

    The geofencing with the phone looks nice, but all too often we don't all carry it with us. And like more people say: you just want a 'shut off till I press you again' button

  • @rgh for now it is only in beta form, but probably will be released officially in a few weeks (source: https://community.tado.com/en-gb/discussion/comment/9730/#Comment_9730).

    @michelvd you can look at @Adrian (tado°) 's post here to see how it currently is implemented (in beta): https://community.tado.com/en-gb/discussion/comment/9587/#Comment_9587

    Or you can just install the beta app and start using it today! I'm using it for a couple of days now and so far it works great. If you are using Android see https://support.google.com/googleplay/answer/7003180?hl=en (section "Get beta versions of apps") for instructions. If you are using iOS, then I'm not sure, but I guess you have to install TestFlight: https://apps.apple.com/us/app/testflight/id899247664

  • edited March 22

    Hi, I'm using the Beta app on Android. When I switch manually to Away mode, the hot water goes to Away mode but the heating doesn't, as shown in the app.

    Additionally, as seen from NodeRed (yes I know it is not official etc) I see this for the Zone Status values:

    {"tadoMode":"HOME","geolocationOverride":true,"geolocationOverrideDisableTime":"2020-03-22T22:00:00Z","preparation":null,"setting":{"type":"HEATING","power":"ON","temperature":{"celsius":20,"fahrenheit":68}},"overlayType":null,"overlay":null,"openWindow":null,"nextScheduleChange":{"start":"2020-03-22T22:00:00Z","setting":{"type":"HEATING","power":"ON","temperature":{"celsius":15,"fahrenheit":59}}},"nextTimeBlock":{"start":"2020-03-22T22:00:00.000Z"},"link":{"state":"ONLINE"},"activityDataPoints":{"heatingPower":{"type":"PERCENTAGE","percentage":0,"timestamp":"2020-03-22T19:05:27.709Z"}},"sensorDataPoints":{"insideTemperature":{"celsius":21.69,"fahrenheit":71.04,"timestamp":"2020-03-22T19:17:35.052Z","type":"TEMPERATURE","precision":{"celsius":0.1,"fahrenheit":0.1}},"humidity":{"type":"PERCENTAGE","percentage":41.5,"timestamp":"2020-03-22T19:17:35.052Z"}}}

    {"tadoMode":"AWAY","geolocationOverride":false,"geolocationOverrideDisableTime":null,"preparation":null,"setting":{"type":"HOT_WATER","power":"OFF","temperature":null},"overlayType":null,"overlay":null,"openWindow":null,"nextScheduleChange":null,"nextTimeBlock":{"start":"2020-03-22T22:00:00.000Z"},"link":{"state":"ONLINE"},"activityDataPoints":{},"sensorDataPoints":{}}

    So it looks like the heating is switched in a different way to the hot water, using "geolocationOverride", and it will stay in override mode until the next block (scheduled for 22:00:00Z).

    No idea if this is a bug, or a symptom of work in progress, or just me misunderstanding something....

  • I can set the presence to Home or Away using the app. The hot water switches off as I would expect, but the heating stays stubbornly on HOME mode. The smart schedule for AWAY mode shows a temp of 10 degrees, which I can change if I like (but it's fine for now) but I can't get the heating into AWAY mode. Will I still need a subscription for this?

  • Fixed it! Not exactly intuitive, and unnecessarily quite a bit of work, but the reason the heating was't switching was that geofencing was disabled on every timer block in the smart schedule, so the away settings were never used. Had to go through the whole schedule, and set geofencing to On, tucked away in the advanced settings for each timer block. Happy it works, but no thanks to the UX!

  • Great that this has finally been delivered. The other heating commands on Google Assistant are pretty flexible language wise but I can't find a phrase that works to set and remove Home/Away modes. Can someone advise what the commands are? I want to add them into existing routines.

  • Yes it is there and works. BUT not what it should be. Away mode is a fixed temperature, should be an away schedule.
Sign In or Register to comment.