Anyone else having problems with radiator thermostats over heating rooms when they should be off?


As I told Tado support after emailing them over and over again about this issue and still not getting it resolved... I am interested to see if other people are experiencing the same as me.

I fitted Tado radiator thermostats to all my radiators along with a room thermostat in the living room and extension kit on the boiler about 5 months ago. For the first few weeks everything seemed good. Over Christmas I started to see problems. Radiators were not switching off when they should allowing rooms to get to uncomfortable temperatures of 24 degrees. I started in one room. I took the thermostat off the radiator, replaced the batteries and it seemed to work correctly again after that.

However, a few weeks later I started to have the same issue in other rooms. I am still getting th I have tried all kinds of things:

  • Taking radiator thermostats off, taking out batteries and putting them back on to "recalibrate"
  • Taking batteries out for an extended period of time (more on that below)
  • Swapping batteries
  • Swapping thermostats from one room to another
  • Putting the old manual heads back on the radiators to check they can actually be turned off - they can without any difficulty.
  • Loads of emails to Tado support
  • One replacement radiator thermostat - that has the same problem

At one point I was told to take a radiator thermostat off and take the batteries out for several minutes. I did - and the whole time the Tado app said the thing was connected and working correctly... Yes, that's right, while it was on the floor with no batteries in. No need to take my word for it, here is a photo to prove it:

This leads me to heavily suspect the issues are server / software related. Added to the issues and outages anyone who has been using Tado for a few months will have experienced - they are leaving me very frustrated. I am wondering if other users are experiencing the same thing? It could just be me - may be the issue is which another part of my system not the radiator thermostats themselves? It would be interesting to know if other people are having the same problems. A few comments on Twitter suggest I may not be alone.


  • jcwacky
    jcwacky ✭✭✭

    Can you add a photo showing the valve body (i.e. without the Tado TRV head on it)?

    I've had Tado for a couple of years now and havn't experienced the issues you have. However, my father has had a couple of instances where a radiator failed to run off, despite Tado thinking it was off, although these issues didn't last long.

    I don't believe it to be a software/server issue though. The default state of a radiator valve (without a TRV head on it) is ON. It's the TRVs job to close the valve to turn it off. Tado TRVs work differently to manual ones, as they use a motor to close/open the valve (instead of an expanding cylinder). Due to it being a motor, it has to "calibrate" to work out at what point to stop pushing the valve closed. This means it will then always stop at this point, so there is scope for this "point" to be different to the point needed to acutally close the valve. Espeically on old or stiff valve bodies.

    I have brand new Danfoss bodies, but those on my fathers are old valves. I believe Tado was having trouble closing some of these old valves, but after moving the pins and recalibrating the issues went away.

    On the radiators in question, have you tried removing the TRV and pushing the pin in and out several times with something solid to ensure it's free to move? Maybe the Tado motors are having problems pushing the pins in for some reason?

    Also, I presume the TRVs are staying securely on the radiators? As when I first got Tado I had an issue with TRVs slipping off the poor adapters provided causing the radiator to always stay on, so I bought metal adapters which stopped them popping off. Although I believe Tado has newer adapters which are much more robust.

  • robertdyan

    I'm having this issue now in multiple rooms. Did you find any solution?

    It's annoying and my room is boiling!

  • Tim
    edited March 2019

    @robertdyan I am waiting on further info from Tado support - they say they have "escalated the issue". This has been going on for weeks - and I have been emailing them throughout that time...

    They resolved the issue on one radiator by "remotely connecting" and recalibrating it. I think I have resolved it on another by taking the radiator thermostat off, removing the batteries, waiting 15 mins and putting it back on. After doing this THREE times it seems now to be working.

    I have already tried the suggestions @jcwacky made and they didn't seem to help unfortunately.

    Right now I am still experiencing problems in a couple of rooms.

  • robertdyan

    so am i.

    they re calibrated yesterday and it worked last night but now they're not working AGAIN.

    Tado, you needbetter customer care and attention

  • Nicatine
    Exactly the same here. Happened twice now. Both times I've managed to get it working again by turning my internet off and on again. After a few minutes the radiator valve switches off. My bedroom is now 28 degrees when it's set to 20. It's like the communication has been lost to the controls but not the app.
  • Hi,

    I think there are a few misunderstandings that I wish to address here.

    1. The devices are not constantly in communication, they only report in every 20-40 minutes unless something special happens (e.g. Open Window Detection)
    2. As such, if a device has its batteries removed, the system will assume it is still online until +/- 30 minutes go by without the thermostat reporting in, even if a device is polled for temperature information (for example) and it doesn't respond immediately.
    3. We are looking into changing this behaviour to give a more accurate representation of the actual state.
    4. The calibration is only triggered once after a reset (e.g. removing/replacing the batteries). If the Smart Radiator Thermostat is removed from the mounting-bracket, it will not (at this stage) report as unmounted or re-trigger the calibration. Again, this is something which we are looking into.

    Best regards,


  • Matt
    I have the same issue and it’s costing me money and uncomfortable at night. When is the fix coming
  • Heatexpert

    I have experienced this problem too. I have 7 SRT (installed Summer / Autumn 2018) and so far around 4 of them have done this.

    I found that the adaptor base that is screwed on to the Myson valve has become slightly loose on those radiators, so by removing it and re-tightening it, then fitting the SRT to the adaptor base (which recalibrates it) solves the problem.

    It is not ideal and I have contacted Tado for a more permanent answer (awaiting reply), but this seems to work.

    I also know that the power usage can be adjusted by Tado (they have done so for one of the SRT), so that gives the motor a little extra power to push the metal pin down. It's possible that all of them will ultimately need to be updated to resolve the issue fully.

    I don't know if this will lead to a shorter battery life for the SRT (I suspect it may do so). As others have reported the SRT works by pushing the pin down to shut the valve, so if the pin is stiff and the motor does not push it fully, the valve will be slightly open, leading to hot water entering the radiator and it heating up.

  • dmanton
    edited April 2019
    I had this problem and it seems the calibration changes the amount of pressure the trv will apply to turn off a radiator.

    The pressure required can be different when the heating is on and off.

    If you are recalibrating turn your heating on beforehand so the water is flowing in the system, then it will calibrate the trv to turn off the valve at the right pressure.

    On one of my radiators the trv was unable to close the valve because the pressure was too high. I adjusted the radiator to lower the flow rate using the other valve. After this the tado was able to close the valve.
  • TtT

    So I can relate to this problem, and seem to have identified the cause!

    I installed 6 radiator valves in December.

    Again, to start with it was fine, then room by room I’ve experienced them heating up way above the set temperature, one bedroom tonight went to 27C when it’s set to 22C.

    In all cases I have found that over time the radiator valve fitting works loose – eventually it becomes unable to turn the heat down – though I think the system thinks it has, hence this issue.

    Tightening it up doesn’t always sort the problem without doing a reset – I think because the system thinks the valve is in a position it is actually not.

    This then seems to be linked to another issue… all my batteries being low! I’ve had notifications of battery low on every radiator that has hit this issue so far - which is all bar one so far! Advises the battery will last a week but in reality it lasts for months! The first room to hit this and have a battery low was in Feb (after just 2 months of use) – still going fine in May!

    I have to admit I’m losing faith entirely with my tado!

    The valves seem to adjust way more than can possibly be needed, quite often a few minutes after you hear it whir, it’s doing it again – that can’t possibly of had any effect in few mins! Why?! This probably exacerbates the issue.

    I have open window detections all the time when there are none – and this is a modern insulated house, no drafts or anything!

    The air comfort report looks like it’s been written by someone high on drugs or something!  Right now for example is telling my my 22C rooms which are nice and comfortable are “cold”… and a bedroom that had the above issue hit 27C – higher than you can possibly set and it told me that was “comfortable” - it was a freaking sauna in there!

    There is now easy way to override the geofencing – for example when you have a house sitter while on holiday, I end up sticking the app on an old phone and leaving it at home! A simple "disable geofencing for x days" would sort that.

    And on warm days with the sun out all day, it doesn’t feel like it’s adjusted to cater for that and we find all the rooms too hot.

    All this is pretty poor, especially given we are now paying a subscription.

    C’mon tado, this is not good enough!

  • makum101

    I've just had this problem and fixed it. . One of my Stats was not fully closing when set to off and allowed heat through if another stat in the house called for heat. here's how I finally fixed it...

    Removed stat from base

    Removed batteries

    Removed Base from Radiator

    Put batteries in stat

    Attached stat to base IN MY HANDS not on the radiator. (difficult to tighten the notch but possible with practice.

    it attempted to calibrate for a little longer than it did on the rad and eventually gave up and displayed the error code 'E4'

    Took stat off base and removed batteries

    Put base back on radiator (rad was warm, not sure if this makes a difference)

    Put batteries back in and attached stat to base (heat was previously set to off)

    It finally calibrated correctly.

    I think making it go into error state sort of reset its memory because it took longer to calibrate once back on the rad after I did that.

  • Knotweed

    I find that the mounting of the Tado radiator stat head to its base is a somewhat hit and miss affair. The heads of mine do NOT click positively onto the base. None of mine has ever clicked. 4 out of 5 now working. Any of you guys having this problem?

  • MexicoMatt

    @Knotweed I have just installed my first Tado setup last night, Thermostat and two TRVs, the first one went on fine, although it did not 'click' or 'snap' (as the instructions say) into place, however it appears to be working. When i installed the second one, it took ages, i could not get it to lock into the base, it either just kept turning, base and all, and then if i tried to turn it back (to see the display) it unscrewed the base form the radiator. I finally got it to connect, but in doing so the bottom part of the TRV kind of broke, and now that rotates, around the TRV, i had to fiddle with it to get the display lined up again. Seems to work fine now, but thinking it is going to be an issue when i have to change the batteries. Not sure what my options are as I bought it as a kit from Amazon and don't want to return the whole (now installed) kit!

  • Regarding the overheating, are your radiator TRV valve bodies in good working order? If the actuator pin cant be pushed down with little pressure the TADO doesn't stand a chance.

    My rule of thumb is that if the TRV's are older than 12yrs old, then replace them. I have had and resolved the issue by replacing them.

  • Same issue in one. Will try (again) to resolve
  • I am having this issue and it has cost be a fortune past week.

    When it hits the temperature it is meant to be at - the heating isnt turning off ... this is on the main stat, not the room valves - so the overall heating! Its set to 18 and going above 22+ overnight and i cant seem to turn it off!

    can anyone help?

  • TtT

    I've had a faulty room stat where the switch was not working - swapped with another and it worked fine, installed the faulty one in another room and it confirmed the fault (I have UFH so a lot of room stats!)

    Sounds like the same problem from what you have said. In which case there is nothing you can do bar replace it.

    tado should replace free of charge it if still under warranty.

  • W1cket
    Having the same problem here - an overheating room has been set to ‘off’ for the past 2+weeks to try and fix it, yet does its own merry thing reaching highs of 29C.

    Might be higher but I don’t have visibility all the time because the Tado is now sporadically disconnecting with the system so the view I get now is that it is having a connection problem with the “remote system”…

    Only installed a month ago. Must do better, Tado.
  • TtT

    Sounds like firstly you possibly have a range issue to the Internet bridge making connectivity sporadic (tado service has been up no outages). That won't help!

    If its a radiator stat that you're using then the overheating issues I've encountered are...
    - the pin in the radiator valve (not the tado stat) is getting stuck... bit of a tap with a hammer might help, I've had that boiling a room before!
    - the tado stat is not secured or working itself loose... some I've found tricky to get a good secure fit - and can start calibrating before they are properly fitted. Others have worked themselves loose over time

    If it's a smart thermostat the only issue I've come across is a faulty unit with a non-functional switch - tado should replace.

    Hope that is useful.
  • Well same here, temp set to 18, rad heating past 20+ non stop for few h and app clearly shows heat 100% on, did set to 16 and it stopped. Complained to support they did something on their end and now nothing would stop heating even if I lower to 10c, so ended up removing room until they respond with solution. Nonsense! Clearly either faulty stat that's installed less than 2 months ago or bad software.
  • featherbelly
    edited January 12

    Thanks for all the various advice. This is what worked for me...

    In summary:-

    1. Turn OFF your heating and let the radiators cool.
    2. Remove Smart Radiator Thermostat from base.
    3. Remove batteries for 20-30s.
    4. Replace batteries in Thermostat (use freshly charged / new if in doubt) and wait for "HI" message.
    5. Reattach the Thermostat to the base and let it recalibrate. N.B. If the heating is ON and other radiators are calling for heat (or were recently) then the system will be pressurised and the recalibration may not work correctly. Specifically the valve might not reach the fully closed position due to water pressure and so even if in the "closed" position there will be hot water pushing into the radiator when others are calling for heat. Hence rads heating up when in the "off" position.
    6. Turn your heating back ON.
    7. OPTIONAL STEPS: Set the Thermostat to call for heat (so the valve is open) and leave for a few minutes and then turn it off to check if the Thermostat is working properly.

    — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — 

    I pretty much followed the general advice on recalibrating. The most important thing is the boiler should be off and no hot water pumping around the system when you reattach the Smart Radiator Thermostat as it might not calibrate properly.