Improve Internet Bridge so it reconnects automatically

2»

Comments

  • Ditsy
    Ditsy ✭✭✭

    @RetsimLegin We definitely had less issues once we started using fixed IP for the bridge, and since 92.1 no complete house failures so far. So if you're not already using a fixed IP, I'd suggest you try it.

  • I started with tado a few weeks ago with the firmware before 92.1 and had almost daily disconnects and had to restart the bridge then to re-establish connection. During my troubleshooting season within my network the 92.1 update was released, and now I have reached an acceptable state of functionality (app. 1 total bridge disconnect in two weeks, but self-resuming the connection, plus sometimes loss of connection to a single thermostat which also resumes itself after an hour or so).

    My measures can be summarised as follows, and I am not sure which ones are the most effective:

    1) Update Bridge to 92.1
    2) create separate native VLAN only for tado bridge and assign Google dns 8.8.8.8 for this VLAN
    3) assign static IP to bridge
    4) set the switch port to 10Mbit half-duplex (not auto-negotiation)
    5) Disable LLDP MED on switch port

    I know that most consumer routers don’t have all these options, but just in case someone has issues with disconnects one ore more of these measures might help.
  • @Jurian I wouldn't know how to determine "if it is an Internet Bridge to cloud issue, or an issue between the internet bridge and the individual devices" except - if the smartphone app states "no remote access" - does that suggest it is Bridge to Cloud or might such an indication arise either way?

    I note your comments about the scheduled connection interrupt. I may try disabling that.

  • Also having issues with my bridge (incorrect status on HomeKit), reckon it’s the 92.1 update since I’ve had Tado for about 5 years and never had any issues with it (nor do I have any issues with any of the 20+ devices on my Velop mesh network, or any other HomeKit device - Tado support already tried blaming Apple, not buying that excuse).

    Using a reserved IP makes no sense as a solution but I tried it, no luck.

    @tado can we get this sorted in 92.2? Otherwise I’ll have to get a smart plug and restart it every night/on demand.
  • As a new Tado customer I’m also not impressed, I’ve purchased this kit to get away from Honeywell & Homebridge integration but at least that’s reliable.

    I’ve tried the daily 3am reboot and it’s a little better for a few hours.

    As I have a Netgear switch I’ve changed the port to 10 Mbps Half to match the bridge, initial first few hours would seem that HomeKit refreshes a bit quicker with a little more reliability. Interestingly, it’s the only device with “high packets received with errors” and collisions. The screen shot is after around 20mins of new logs. I’ll post an update with new stats tomorrow.


  • 4 Hours on… changing the port speed hasn’t made a sufficient improvement. To ensure the packet loss isn’t my infrastructure a different port and different cables still show the same issues. These stats took just a few minutes.

    Just to be clear what not’s reliable, usually it’s multiple “No Response”.


  • @MySmartHome From Netgear documentation:


    Packets Received With Errors

    The number of inbound packets that contained errors preventing them from being deliverable to a higher-layer protocol


    Multiple collisions:

    A count of the number of successfully transmitted frames on a particular interface for which transmission is inhibited by more than one collision.


    In a half-duplex connection collisions always happen for a small percentage of packages (but not with full duplex connections though). After a collision the package is resend after a random time. More interesting would be to know the number of Excessive Collision Frames. Maybe you can find them in Port detailed statistics on the Netgear switch. With Excessive collisions the transmission fails completely.

    You already changed port and cable, so Packages containing errors are a clear indication of an issue on the sending side.

  • Hi, here’s all the available stats from the port.

    I’m unclear if an issue on the sending side is aimed at my infrastructure or the the IB? I see from several articles that for most users the issue of failing to update the status of devices in HomeKit is very common, but a new problem. I’ve also seen responses to indicate it’s difficult to replicate in a lab environment so I’m more than happy to try anything you suggest. I have quite a suite of HomeKit items from many vendors and none of them exhibit this problem. The closest issue was the updating of camera thumbnails but that was fixed in IOS 15.3


  • @MySmartHome I mean with sending side the Tado IB.

    The detailed port statistics shows your Netgear port g23 is in 10 mbit full duplex. It should be on half duplex 10 mbit.

  • The Rx FCS errors are serious. They point to cable errors, electro magnetic interference, or IB interface faults.

  • I also noticed the detailed report was full duplex and should read half, the port configuration confirms it’s half.

    The serious Rx FCS errors, I’m still unclear if you agree that it's your or my problem? Given I can plug into any port with the same issue and that no other device has any issue I don’t yet see how that’s my problem?? And, more importantly, is this a good direction to working out why for soo many users HomeKit fails to get the status? It leads to your problem.


  • MichielTado
    MichielTado ✭✭✭
    edited February 2022

    @MySmartHome to be clear, although my name suggests it, I am not affiliated to Tado in any way.

    As I said before, I agree that it seems that the Tado IB ethernet interface has an issue.

  • Entertaining, but of zero help ;)
  • @MySmartHome any luck yet?

    I seem to be facing the same issues, all solid LEDs, but still no connection. I have a Nokia Mesh network
  • Hi, yes, but with zero help from tado, their tech support is useless. So, a “short” story of how and where I’ve got to, I think it sets the scene for tado ;)

    I have a 48 port POE 1Gbps switch with CAT6 infrastructure cabling to the end points in each room for wired devices. The 1Gbps Internet provider router is also plugged into the switch, no other part of the providers services are used. WiFi is provided via 5 access points broadcasting 3 SSID, 5GHz, 2.4GHz and a guest with shared frequency. Many “modern” devices such as Nanoleaf fail to connect under a shared frequency single SSID hence splitting out. Band steering doesn’t help with that. In terms of HomeKit, I have 100% LightWave switches with dimming bulbs (there’s another “short” story around how their product doesn’t need a dedicated neutral, but that’s for later). I chose LightWave as it “didn’t need a neutral” and being HomeKit compatible, well, mostly. 100% of windows and doors (including the loft door) have LightWave magnetic sensors. Every room has an IKEA Tradfri motion sensor. Garage door is covered with a Meross garage door opener, another “modern” brand that needs to see 2.4GHz. Home cinema is Philips Hue comprising HDMI sync box and LED strip around the screen, the rear wall has 2 Philips white & colour. The front doorbell is Doorbird as it, at the time, was about the only doorbell with a network cable and POE support, so no recharging of batteries. On the Apple front, there are 2 Apple TV and 2 HomePod mini. There are OEM hardware bridges for Philips, IKEA, LightWave and now tado. Non HomeKit items are covered with HomeBridge and a few plug-ins, notably Homebridge Security System, Homebridge Doorbird, Homebridge Security System and Homebridge Camera FFmpeg for CCTV into HomeKit. Various NFC tags and miscellaneous buttons finish it all off. Recent additions are a couple of Eve power.

    • tado Tech suggested I have all my IOS devices on 2.4GHz, not 5GHz. They clearly don’t understand the Morden world, WTF? why would I put my devices on a slower WiFi? Yes 2.4GHz has better penetration, but what happens when I leave home? Am I going to ask Vodafone to change the frequency of 4G or 5G? tado’s suggestion just makes no sense, but for humour, I tried it, and it made zero difference.
    • tado suggested different orientations for the bridge, that’s doable but at the end of the day the chewing gum sized bridge might need some chewing gum to hold it in a different position. I have a Prusa so a mount will be made shortly.
    • After a lot of sarcasm from me to them they said the case would go to Second Level support. Still waiting after 2-3 weeks…
    • They steered me away from range extenders.
    • tado then suggested I trouble shoot for a faulty valve. Really? I have 9 TRV and they suggested they could all be faulty. That’s not a good thing for tech support to say on any day. I passed on that idea.
    • tado then suggested it’s a channel issue. Err, no! The tado app works a treat but not what I want to use. It’s HomeKit that’s a consistent fail at this stage. The channel idea would be great if the tado app failed to connect.
    • It’s at this stage I thought I’d send it all back and stick with Honeywell Evohome with the HomeBridge plugin. But…See the next post.
  • My HomeKit home isn’t just out of the box, many things have needed a tweak as the manufacturer clearly didn’t market it properly or finish their testing. For instance, LightWave, they state it needs no dedicated neutral, that’s mostly true, but it’s not defying the flow of electricity. What they tuck away in the very small print is that every bulb has to be dimmable (or incandescent in the old world). You may (or may not) ask “why?” Well, the dimmable bulb is actually on just enough to pass a very low neutral return which is also low enough to not perceive the bulb being illuminated. So, no neutral required, but I did need to replace all my LED’s with dimmable versions. Oh, and don’t forget the LightWave approved list is small, so you’re on your own to check it all works. I chose LightWave magnetic sensors as they’re were low cost. But that of course means they’re not Thread and had issues of range & connectivity. Not just “out of the box” means I modified the antenna to increase the length which cured all the issue that steel lintels above openings gave me.

    So I think I have enough experience to throw at tado to try to get it working, and working it is!

    Things I have found along the way that finally answer your question…

    • I initially paired all the tado TRV’s and left them in a line for testing and integrating into HomeKit scenes. My plan was to do as much work up front before switching out with the Honeywell. However, I have come to a conclusion that if you don’t mount the TRV it goes to sleep and stops connecting. Mounting it removes the red spanner icon in the app and fixes the first of many issues. You can of course then un-mount again. The pointer for this was that the tado wireless thermostat was reliable from the start.
    • My next finding is indeed range and orientation of the tado bridge, for me that’s reasonably easy to fix via trial and error with 48 endpoints to choose from around the house. But the overall best result is actually when the bridge is in the loft as downwards has less brick to penetrate. tado do suggest they can cater for 2-3 stories pending construction materials. I’m not yet convinced that vertical mounting of the bridge is best, that’s still to be finalised.
    • I think any loss of connection between then tado TRV and bridge sends the TRV into a downward spiral of sleep and connection loss AKA “updating” in HomeKit. If that happens a manual twist of the TRV to alter the temperature seems to fix. Then go back to look at why it lost connection, hence the orientation of the bridge. I’ve never had any of these issues with the Honeywell, both use 868MHz so in theory have the same ability to penetrate the walls. I’m assuming the Honeywell has better antenna, back to my LightWave magnetic sensors…I live in hope that tado will use thread at some point as that’s 6LoWPAN and runs at 868MHz. It can’t be that hard, can it?
    • Next issue(s) are actually Apple. The Mac HomeKit app seems to be much better and doesn’t have the “updating” issues, it seems to be more iPadOS and IOS related, even after the successful 15.3 thumbnail fix.
    • I noticed by chance that the Apple TV 4K wasn’t as stable as a Hub compared to a HomePod mini. Disabling the Apple TV in HomeKit really improved things and even made me think tado was half decent. For a while anyway. To keep a degree of redundancy I bought a second HomePod. It’s at this point I lost the plot as I noticed the new HomePod was even more stable. WTF, really? If you read enough about these issues you’ll uncover that many users find they need to regularly reboot HomePod’s. My overall thoughts and conclusion is that Apple TV isn’t as good as the HomePod. But the HomePod does need regular reboots, perhaps up to 4 days and then it needs a kick. Of course you can’t use an automation for that, and so an Eve power is in place, an IKEA Tradfri works just as well for much less spend.
    • On the topic of reboot’s, I also found that the tado bridge needs frequent reboots. My setup means I can use POE (via a USB splitter) from the switch, the switch has the ability to reboot on a port by port basis to a schedule. So every evening at 0300 it gets rebooted.

    Lot’s of things to juggle for stability but once you work that out and get reboot schedules in place it’s good. I’m now not convinced that tado need to address any issues via firmware for the “updating” but if they can change channels on our bridge from their end, why can’t we? It would be good if they could look into anything that seems to send the TRV to sleep. Maybe there’s no such thing, so it’s my perception for now. Do I think it’s all fixed and stable? No, not yet, but it’s much better than it was. The Honeywell and HomeBridge isn’t perfect either, any issues with HomeBridge and you have to put the TRV’s back into the correct rooms in HomeKit.

    I have lot’s of automations in place for windows open, schedules and Gefence via HomeKit, but you only asked if I’d had any luck yet…

  • johnbur
    johnbur ✭✭✭
    @MySmartHome very detailed post indeed I'm sure, but most of it is not relevant to this thread which is solely about the Internet bridge not reconnecting to the Internet.
    For me it was solved entirely by setting the port to 10mbit half duplex. I have not had a single disconnect since last August.
  • It’s great you found a fix that works for you. As for which category, this thread is aimed at “Improve Internet Bridge so it reconnects automatically”, that’s a tad”o” generic anyway IMHO. It could be perceived that an IOS app that’s stuck on updating has an issue with the Internet Bridge that’s failing to connect automatically ;)

    I don’t mind if tado decide to move or delete it. It’s only a few misplaced words, hopefully it won’t start a war.

  • I thought I'd just add to the original theme of this thread after several months.

    In this post above https://community.tado.com/en-gb/discussion/comment/30831/#Comment_30831 I considered adding a mains timer switch to the Bridge's PSU so as to power it down and back up daily at an inconspicuous time.

    I did exactly that shortly afterwards. And since then, my system has never (touch wood) failed to operate correctly.

    I was prompted to add this latest observation after my Modem/Router advised of some updated firmware a few days ago. Whilst I'd normally leave it to apply this itself during the night, on this occasion I chose to manually apply it whilst I was watching. As always, this involved the modem/router restarting itself. And sure enough once that had happened, everything was working fine except the Tado bridge, which did not reconnect. A power cycle recovered it.

    So the mains timer switch is going to stay right where it is for the forseeable future. This is the single best thing I have done to work round the problem highlighted by the headline of this thread.