Opentherm, flow temperature and weather adaptation.

I’ve just had my boiler replaced with a Vitodens 100 Combi. I have an existing Tado setup with SRV throughout. It was connected to the old boiler in switch mode. I’ve connected to the Vitodens via Opentherm.

My questions boils down to how much control does Tado have over the boiler via Opentherm, and what takes precedence, the boiler or Tado?

  1. Can Tado change the flow temperature? I see it changing, but what is controlling it?
  2. If it can, does this mean Tado weather adaption does this, thus rendering Viessmann’s own weather compensation unnecessary?
  3. If I did fit Viessmann weather comp, which takes precedence?

One more thing. A Hot Water control has appeared recently, this doesn't affect DHW temp for me, I guess it’s aimed at system boilers. Can it be removed from the app?

Best Answer

  • GrilledCheese2
    GrilledCheese2 ✭✭✭
    Answer ✓

    Some combi boilers have a pre-heat function for the hot water. There’s a small internal store of hot water which means you don’t have to wait so long to get hot water out of the tap. Turning on the function will use more gas, even when the hot taps are not used. Tado hot water control allows you to schedule when this function is active. Your boiler has the pre-heat function, which may be why you see hot water control in the app, but not sure. Another question for you to ask Tado customer support.

Answers

  • Following my close observation of the boiler, confirmation from Viessmann UK tech, GrilledCheese2's input and some worryingly inaccurate information from tado, here's what I think is going on. Further info or corrections are welcome!

    1. tado does control the flow temperature (initially tado support said it didn't!), and it seems to be based on load. With tado connected to the Vitodens 100 in Openthem mode, it is not possible for the user to change the flow temperature. You can only observe the current flow temp and what I take to be the set flow temperature. When the house is cold the set flow temperature is 80C. The boiler ramps up to this and modulates the burner accordingly as the temp is reached. Once the internal temperature has stabilised, the set flow temperature begins to reduce significantly, sometimes <25C. Once this threshold is reached the boiler fires until the actual flow temp is (say) around 40C. Should there be a sudden demand for significant heat, say a cold rad coming into schedule, then the set flow temperature will rise significantly until the load stabilises, then it slowly reduces again.
    2. tado didn't confirm whether any Weather compensation algorithm plays a part in this, but given the load compensating which will presumably be influenced by rate of heat loss, I don't think that it is required.
    3. tado confirmed that the Viessmann weather compensation would work with tado in Openthem mode, but it would defeat the tado control to the point where tado will only turn the boiler on and off.

    GrilledCheese2's assertion is correct. In order to get this to work on the Vitodens 100, it is necessary to switch the boiler from Eco mode (where there is no pre-heat), to Comfort mode. Once enabled, with hot water scheduled on, the boiler remains in Comfort mode, when off, it returns to Eco mode.

    Notes:

    In theory, switching from Eco to Comfort mode should be done by the installer. Details are in the installer documentation.

    I have had the boilers rated heating output significantly reduced, as it's output (30Kw) is a bit over the top for a property with a calculated heat loss of 7Kw. 30 Kw is good for hot water though!

    When the system load is low, say when the house is at or very near set room temperatures, whilst the boiler rarely fires the pump runs for long periods when a rad has a slight demand and the the flow temp is low. This makes sense when trying to raise a room from 17C to 18C with a flow temp of 30C. It's going to take a while, but are these long pump runs desirable?

  • Thanks for posting the detailed observation.. That's very useful! I've seen similar observations for modulation with my Ideal Logic combi wired with Opentherm.

    That's a shame Tado doesn't take outdoor temperature into account for modulation. I guess if you want modulation taking into account outdoor temperature you install the manufacturers compensation kit and wire Tado in relay mode.

    Someone else also got a similar response from Tado: https://community.tado.com/en-gb/discussion/7005/what-actually-is-weather-adaptation
  • From your observations of the flow temperature behaviour using Opentherm, I suspect you'll use less fuel with the boiler weather comp than the Opentherm. If you're getting a heating flow temperature of 80C your boiler is not condensating and is therefore probably around 80% efficient then, as opposed to the potential mid-90%.

    If you're interested in comfort and efficiency, take a gas reading and run your heating for a week as it's currently set up. Take another reading.

    Then set up as follows:

    1. Switch the OpenTherm off and the Viessmann weather compensation on (I'm assuming you have the external sensor connected?)
    2. Find the weather comp curve setting that maintain the temperature inside, but pretty much no more. This will probably take a few attempts. Expect the house temperature to rise, but only quite slowly - maybe 0.5C per hour at the most. If it starts falling, you've gone too low.
    3. Set tado to use optimal start and set to reach target temperature for when you get up. Make sure that temperature is set to about 1.5C higher than you want it to actually be and it'll hit the temp you want it to be (not the target).
    4. Set tado to turn the heating off (not down) at bedtime. This way the optimal start will ramp up smoothly (if you set back it be turning on and off all night trying to keep to the set back. In practice, it won't fall that far before the optimal start kicks in.
    5. Do not set a deep daytime set back. The heating will not recover. About 1-1.5C is about right.
    6. Use eco away mode on tado. this sets back about 1.5-2C as soon as you leave the house. If you're nearby, that won't effect much of a setback because your heating will be running below the set temp anyway (see 3).
    7. Use your TRVs, particularly in the room with the tado sensor. (Ignore the advice not to do that). Set it about 1.5C below the target on tado (i.e. what you want it to be). That way, when the room is occupied, the body heat will not switch off the heating to the whole house. Instead, the TRV will reduce the rad flow and the end result should be just about under the set temp.

    Take gas readings and run for a week before taking another reading.

    You will find your heating runs all the time during the day when you are in, but it will be amazingly quiet. You will probably think it's off. The house temperature will fluctuate almost imperceptibly. You will likely panic that you are sucking gas by running the boiler for so long, but if the curve's right it's going to be modulating down (and even off) most of the time, so 'on' doesn't mean 'burning'.

    See how you get on. I've been running a mark 1 tado (no Opentherm) with a v100 system and TRVs since tado launched in 2013. I've tweaked the system every year seeking improvement and have found this is the optimum balance of comfort and efficiency on my system. It will be different for you, but I will be very surprised if the tado OT is not messing with the v100's weather comp and giving you a worse outcome.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!