Early Start Phone App UI changes.

I was asked by Tado˚ to start this discussion, so here goes. In the Web App when the room is calling for heat due to "Early Start" it is shown in the UI like this.

But, this does not show in the Phone App, so you think the room is calling for heat for no reason and can be confusing...

2
2 votes

Active · Last Updated

Comments

  • rafm5
    rafm5 | Moderator

    I am not sure why there is a need for this topic to be discussed as to me it is a bug, not really a request for a new feature.

    A consistent user experience, regardless of platform is one of the key component of a well designed GUI.

  • andyblac
    andyblac ✭✭✭
    edited March 15

    I said the same to the Level 2 Engineer that ask me to post this 😦

  • Rob
    Rob | Admin
    edited March 16

    Not sure what's going on (bug or feature), but I'll bring it to the attention of the app designers.

    @andyblac @rafm5

    I just tested it on my private Android phone in my private tado° account (excuse the Dutch language; 'Vroege Start' = Early Start), and it indicates Early Start on mobile as well.

    Mobile:


    Web app:


    So, from my perspective it works as expected? The only difference I see is the 'for 2:15 PM' part.

    If you're seeing something else in your app, please make a screenshot of the app as well.

  • andyblac
    andyblac ✭✭✭
    edited March 16

    not shown in the iPhone app. soon as I can I will.

  • andyblac
    andyblac ✭✭✭

    @Rob as requested

    WEB UI:


    iPhone App UI:


  • rafm5
    rafm5 | Moderator

    @Rob @andyblac Just tested this on iOS 15.4 and the 'Early Start' message doesn't appear on Apple devices.

    Should we agree that it's a bug?

    Also as in your case the WebApp uses AM/PM 12-hour clock system opposite to 24h for iOS.


  • Rob
    Rob | Admin
    edited March 18

    The webapp uses settings from the browser/OS. I guess my work PC is set to US settings or something. That's not the issue. This works fine on your end. The issue seems to be that the Early Start notification apparently does not appear in the iOS app, even though it does in the Android app.

    I'll forward this to the iOS devs.

  • andyblac
    andyblac ✭✭✭

    @Rob Thanks, Hopefully they can fix for next release.

  • Rob
    Rob | Admin

    The fix for this issue is now part of the public beta (6.38) and will probably go live next Monday. Thanks for the feedback!