Home Technical Questions

TRVs won’t grip. Guide says no adaptor needed.

Hi, installed my tado heating setup yesterday. Got extender, thermostat etc all up and working, started on the TRVs.

Old one, a pegler terrier ii came off easily enough and the new one seemed to screw on. But then I noticed that the instructions involved twisting and clicking, which of course secures the the two parts of the TRV. The value would just keep rotating around when I moved it and no click.

the underneath of the TRV that’s suppose to grip onto the metal hexagonal mount is wider than the one that comes with the radiator.

i couldn’t see how any of the adaptors provided could resolve that/


on here it says no adaptor needed. Am I doing something very obviously wrong?

Answers

  • samdsamd ✭✭✭

    @Gaz Hi - I am struggling to see what you mean by the hex mount.

    Is this what you have?



  • GazGaz
    Yes. I can’t add pictures. The trv fits the ring and screws on but it doesn’t grip on anything once it’s screwed in. Unlike the one it replaces. Because it doesn’t grip when I turn it to click it into place it just keeps turning.
  • samdsamd ✭✭✭

    @Gaz Does this help in anyway?



  • samdsamd ✭✭✭
  • GazGaz

    Unfortunately not. The adapter seems to be for the slightly smaller rim. The metal part of the TRV screws on perfectly well. It just can’t grip the thing inside. The adapter is for slightly smaller metallic rims. So won’t fit on.

  • samdsamd ✭✭✭

    @Gaz OK understood. If you have pushed the plastic 'legs' of the tado trv as far as they will go AND if you have fully tightened the metal ring, then I can only suggest the tado chat line on tado.com - sorry!

  • GazGaz

    Thanks. Was going to that tomorrow. Frustrating as all but one of the radiators in the house use the same valve type.

  • GazGaz

    Ignore my stupidity. I just hadn’t tightened the valve enough for it to lock. Got it working.

Sign In or Register to comment.