Update from the tado° Heating Installation product team about the Zone Controller Feature


We would like to share some of the smaller product improvements that the Heating Installation product team has been working on.

The primary reason is to get feedback from our community to see if certain features are clear or if more clarity is required.

As the Heating Installation product team we mainly deal with the DIY step by step instructions that we provide to each customer. Furthermore, we want to improve the settings page to allow you to make adjustments to the configuration of your tado° products in your own account.

As you may know, if you have multiple tado° devices in your account, they can communicate with each other to control the heating together. Whether they communicate or not, however, depends on the configuration of the devices in your home settings. Whenever you add a new tado° device to your account, a default setting for the communication is applied. We at tado° put a lot of thinking in our defaults with the goal to cover most setups and installations. But we are also aware that these default configurations do not fit every heating system, that is why we are working on implementing further settings in your app to allow you to set up your tado° system without the need to contact our support teams. 

Since recently, you can change the configuration of the Smart Thermostat in your account. By default, it’s set as a Zone Controller in your home, but this can be changed based on how you select to install the Smart Thermostat:

For certain situations, you might want to use your Smart Thermostat as a Wireless Temperature Sensor. When you choose the option to install the Smart Thermostat as a Wireless Temperature Sensor in the app, its configuration is automatically to purely measure the temperature. To be able to actually control your heating system, you need to either have it in the same room as a Smart Radiator Thermostat or have it assigned to a Zone Controller (such as a Wireless Receiver or Extension Kit).

The option to install the Smart Thermostat as a Wireless Temperature Sensor is given when you click on “Installation Instructions” for the Smart Thermostat for the first time. Later, it’s accessible when you go to Settings > Rooms & Devices, select the room with the Smart Thermostat and click on “Zone Controller”. You’ll then see the option to “Reconfigure as Wireless Temperature Sensor”.

For other situations, you might want to actually use the Smart Thermostat as a Zone Controller. This is the default configuration but in case you already made changes to the defaults, you can always restore the Smart Thermostat as a Zone Controller: Go to Settings > Rooms & Devices, select the Smart Thermostat and click “Installation instruction”. Select the model you want to replace with the Smart Thermostat to wire it to your heating system. After you select the model, the Smart Thermostat is automatically configured as a Zone Controller again.

We are continuing to work on other related topics and will post further information in this thread once features become available.



  • Heleen_60
    No idea what this post is about! :#
  • paul0000
    paul0000 ✭✭✭

    I understand the post, but why would anyone want to configure a smart radiator thermostat as a wireless temperature sensor.

    I think it[d look a little weird sat on the window sill or table to measure the temperature!

  • paul0000
    paul0000 ✭✭✭

    @GrayDav4276 You're right :) - thank you. My post above can be safely ignored.

    Thanks for pointing out.

  • If we can set the thermostat as a temperature sensor than we can have more thermostats, on in every room, set as a simple temperature sensor and then we can have all the temperature data in the app. That is a good ideea

  • I thought I'd give an example of when you want to to have the Smart Thermostat as a Temperature sensor.

    Our radiators are under the windows so the TRVs generally read a bit colder than the reset of the room. Having the Wireless Stat allows the true temperature to be read. You could offset the TRV temperature but when the sun come out the effect is lessened.

    Also the TRV temperature reading rises very quickly when the radiator is turned on. Having the Wireless Stat allows the ambient temperature to be used to turn off the heating when the desired temperature is reached.

  • yrros

    This is useful though for the smart wired thermostats I think you need to surface some of this functionality to the user (and more options too)

    Here's my set-up and the challenge:

    I have a boiler with a wireless receiver attached to it.

    I have radiators on the top-floor attached to the boiler's controller (now with Tado TRV's on them)

    on the ground floor, I have wired thermostats to operate the underfloor heating in several rooms. The underfloor heating thermostats are attached to a 'sub controller' which is used to turn on the pump, this sub-controller will remain in the 24/7 mode and only switches on the pump when there's a heat demand from a wired thermostat. The required mode for these Wired Smart Thermostats to correctly operate the heating is to:

    1. Call for heat (on the boiler / wireless receiver / a zone controller)
    2. Connect 'Common' to 'Normally Open' on the wired smart thermostat relay.

    Today this option is not in the app; they seem to either throw their internal relay or call for heat on the Wireless Reciever (or another zone controller).

    Fortunately, I've found that if the smart thermostats are factory reset and not manually configured, this is how they operate (local relay and wireless receiver call). My hope is Tado will allow users to select that the wired smart thermostats can be configured to both calls for heat on a zone controller and also switch on their local relay.

    I can't be the only one with this set-up.

    Thanks for your ongoing development and support Tado team.

  • Hi German,

    I hope this comment reaches you.

    I have followed once again the instructions mentioned above to set the Wired Smart Thermostat as a Zone Controller. Despite all my efforts, the app does not reflect this. The only Zone Controller available in my options is the Wireless receiver installed to control the hot water in the water tank.

    I had a Siemens RWB27Si prior to installing the Wireless receiver and your team had to create tailored instructions for me. These device used to control the hot water in the house.

    The installation instructions included 2 bridges, from L to the CH No and from CH No to HW No.

    Would a solution be to remove those bridges and add one just from L to HW No? Would this trigger for the Wired Smart Thermostats to behave differently and show in the app in the Zone Controller's drop-down list?

    Thanks :D

  • Hello Germán

    I am a new customer for Tado and your question from last year is at the very heart of the problems I am experiencing. The support chat has been unable to help.

    There are 3 Wired Smart Thermostats in my house.

    Zone 1 - Controls UPSTAIRs, Zone 2 - Controls DOWNSTAIRS, Zone 3 is and annex room.

    I would like to set the Tado room TVRs to use use the Zone controllers. For example:

    OFFICE to go via UPSTAIRS to open the valve and turn the boiler on. LOUNGE to go via DOWNSTAIRS to open the valve and turn the boiler on but I cannot find anyway to make this work, I have contacted Tado, support, I have read almost all your help documents and I have joined this forum but still no-one can provide a solution. are you able to help?

  • Hi

    i am experiencing a similar problem

    i have 4 wired thermostats, 3 dealing with 3 underfloor heating zones on the ground floor and a 4th which replaced an old thermostat controlling 8 radiators on the upper fLoors which are all, apart from one, fitted with Tado radiator valves.

    I would like to control each radiator separately without having the 4th smart thermostat constantly on

    tjere is no option about zone controls on any of my thermostats



  • Kashx81
    Is there any solution to this. I have two wired thermostats, one for upstairs and second for downstairs. Upstairs one is set as zone controller and I want the downstairs one to be also set as zone controller but app doesn’t let me. Even if I follow Tado instructions which say go to setting: room and devices, select thermostat and click installation. That just shows me how to replace my old thermostat which I have already done ages ago. There must be an easy way. Can anyone help?