Set the "Sleep" functionality of my Midea Air Condition from the App

Issue

The air condition Midea Silent Cool 26 Pro WF is equipped with a so-called "Sleep" functionality. Activating the feature via the included remote control or on the device itself makes the AC turn into a more silent operation mode, the fan speed is set to "Auto".

Tado is not respecting this setting and is always overwriting it whenever it sends a command to the AC.

Expected Behavior

Whenever tado is sending a command to the AC it should also include this setting.

When the feature is turned off on the AC, tado should be able to turn it on, (and set the fan to auto).

When the feature is turned on on the AC, tado should be able to turn it off.

Possible Solution

Include the "Sleep" setting into the command set, as it is shown on the AC's remote - see image attached, the setting reflects in a moon with a star symbol being shown on the remote's display.

1
1 votes

Active · Last Updated

Comments

  • Here you can see the "Sleep" symbol on the remote's display.