Tado app gets "Heating to" temp wrong and keeps overheating the house

For ages I've had no problem with the Tado system.

But for the last few weeks this keeps happening:

I set the tado app to heat the house to - for example 19.5c

All good - house heats up, but then overheats to - for example 20.5c

The tado app registers the "Inside now" temp as 20.5c - correctly

Instead of turning the heating off Tado leaves it on!

Setting the temperature lower in Tado does nothing.

The only solutions seem to be to turn the boiler off and on again

I've tried force closing the app etc.


The app actually seems to be turning ON the boiler in order to be "Heating to" a lower temperature.

I can see the boiler receiving a request from the Tado thermostat for "More Heat" (Flashing rad icon)

I'm getting cooked here!


To confirm the usuals:

My iphone is up to date

My Tado app is up to date

The Tado Thermostat is connected to the wireless bridge and the boiler and has working batteries

The Tado Thermostat is reading the correct temperature.

The bridge is connected to my router, everything is connected to everything else

The boiler (Vaillant Ecotemp) is working fine.

The whole system used to work fine.

Best Answer

  • HotPotato
    HotPotato
    Answer ✓

    SOLUTION! - After a few emails to Tado support showing my screenshots - here is my experience:

    ----------------------------------------------------------------------------------------------------------------------------

    Their response on seeing my screenshots that show completely wrong "heating to" performance:

    "Some of it is expected behavior, some of it is not."

    "I have changed the settings in your account just now."

    "If you do not see a clear improvement, please let us know."

    The gist of their response was that there is nothing wrong with their app - but also at the same time - maybe there is something wrong, - they seemed to imply maybe it's about my misperception of what the Tado system does, or that my expectations are too high.. - Even though I had screenshot evidence of the errors in the app.

    ----------------------------------------------------------------------------------------------------------------------------

    This was their response to me asking if the app might have developed a bug in the last month or so:

    "We have not changed anything that is relevant to the way we ask for heat in the last few months. The weather has changed though."

    I found that last sentence amazingly patronising!! Duh! Even a squirrel knows when winter is coming - do they think their customers are that stupid!!

    ----------------------------------------------------------------------------------------------------------------------------

    So.... Final result - when Tado "changed the settings" at their end, the "Heating to" error dissapeared - but only about 36 hours after they made the change.

    The app always reports correctly now for me - but Tado deny there was ever a problem. I mentioned that others here are experiencing the problem.

    ----------------------------------------------------------------------------------------------------------------------------

    My feedback: I've been gaslit by Tado support - but at least my gas central heating is working now :)

«1

Answers

  • HotPotato
    HotPotato
    edited January 31

    Here's a screenshot:

    It never used to be like this.

    (edited to fix embedded image)

  • samd
    samd ✭✭✭

    @HotPotato Even though it is a jpg, it claims not to support that file!! Did you do it using the 3rd icon bottom left?

  • Edited the post to fix

  • Anybody else have this? I have the same.

  • Hi Thistle - can you list your hardware/app setup compared to mine?

    Maybe we can do some deductive reasoning?

  • @HotPotato & @Thistle out of interest how long do your rooms over heat for? I know the Tado system is not constantly monitoring and changing power levels etc because it drains the batteries too much. So there can be a period of time between Tado making adjustments to keep the room temperature within acceptable limits.

  • Thanks GrilledCheese.

    I get so hot I have to switch the boiler off, so I have not let it "time out" - yet...

    Next time this happens I will leave it overheating and see how long it takes.

    (within reason - i.e I will wait as long as I can before I get ridiculously hot)


    You mention this:

    "there can be a period of time between Tado making adjustments"

    Is there any way of us knowing what this period / time range of time could be?

    Is this official information from Tado or more of a gut feeling?

  • The time range seems to vary and is based on what I have observed when pulling information out of the Tado API.

    This a screenshot for one of my zones making adjustments to temperature changes this morning.


  • HotPotato
    HotPotato
    edited February 2

    Thanks GrilledCheese,

    Awesome work - I can't figure out what it means though - is the jump from

    11:53:25

    12:00:07


    Some kind of indicator of a change - do you think there's a way to learn the "acceptable time to wait for a change" from this data?


    Regardless of whether this data can be used to learn more,

    I feel certain that the Tado app saying "Heating to" = a lower temperature is a bug in the app.


    There's no way I could fill a kettle with hot water at 30C, then set it to "heat" the water to 20C - but this seems to be what the Tado app says it is doing.

  • The power and sensor time stamps show when the values are re-calculated and acted upon. It looks like the interval can be up to 20 minutes, which shouldn’t be a problem as room temperatures are normally slow to change.

    Tado will overheat my rooms a bit, but with your excessive temperature increase it made me wonder how much time had elapsed.

  • Hi @HotPotato,

    Have you got an answer to your issue....I'm currently experiencing the same problem.
  • Hi GrayDav,

    Warm greetings!

    Tado have got back to me and asked me to tell them when these issues are occuring for me.

    So when I have the time this weekend, I'm trying to take a screenshot on my phone, like I did earlier in the thread.

    (Not sure why they can't use that one as proof TBH)


    Hopefully they can figure out what's going wrong.

    While we wait for the solution - Don't forget to keep posting in this thread - that way it stays visible.

    Or start your own thread :)


    I will make sure I keep this thread's staus as "not answered" - which I have to do manually, every time somebody (or me) replies.


    You can find out more on how to stop "Fake Question Resolutions" on the tado forum on this thread:

    https://community.tado.com/en-gb/discussion/8193/how-to-get-your-forum-question-answered-properly#latest

  • HotPotato
    HotPotato
    edited February 9

    I'm posting some evidential stuff here in the form of screengrabs from my iphone.

    Hope it might be of use to any of the folks out there who are getting cooked or frozen by their Tados and trying to compare notes:

    Sometimes it feels like the Tado is broken all day and night - then sometimes it's OK

    I could leave it overheating for hours (and sometimes it does when we go to bed) , but generally I have to kill the boiler to avoid getting too hot.

  • @GrilledCheese2 - from the data I have gathered the error state can last for many hours - so I don't think this is a rounding error between cycles / states.


    And of course - "It used to work fine" - I do think the only thing that has changed is a software bug.

    I will be the first to apologise if it's my hardware - but other's have the same issue starting this year

  • sdmaino
    sdmaino ✭✭✭
    edited February 9

    Same thing here: often but not always, the boiler stays on...

    At the moment I fixed it via IFTTT

    IF room temperature is >xxx THEN turn Tado OFF for 10 minutes

    I did set it up only for my daily comfort temp

  • Pete
    Pete ✭✭

    @HotPotato

    I have similar issue with over shooting target temp in some rooms. I always put it down to delays due to poor signal between the TRV and bridge. Are the rooms furthest way from your bridge the worst?

  • Hi Hotpotato

    we have the same problem and it’s in the same room as the bridge. We turn valve off by hand or by app and it turns it self back on later (but app says it’s off) and the rad is heating room to 25! I’ve sent a message to tado. Let’s see if they can help because my elderly father lives in that room and can’t breath/sleep due to heat.

  • Pete
    Pete ✭✭
    @Tempy
    One thing I did notice a while back was that some TRVs would seem to lose calibration and heat the room when off (not sure if the problem was with the valve or the TRV).
    When it happens I simply disengage the TRV, take the batteries out, wait a moment then put batteries back and latch back onto radiator valve. The valve would then go back through calibration again and fix the problem.
  • Karmageddon
    edited February 16
    I'm finding the same issue. I have owned the unit for a few years but never used a schedule. Preferred to just manually put it on when required in the app.

    Couple of days ago, circumstances changed and decided to create a schedule. Set the temp to be 20.5 for 2 hours in the morning and evening.. In the evening it seems ok and worked-ish, the next morning when it came on, temp shot up to 21.5 and it was still demanding more heat!! Needless to say worst thing that could happen when you have a 3 Yr old.

    After analysing the graph, not happy with the scheduling at all. It seems to stay on for the full 2 hours Heating even though it's hit the required temp, resulting in massive overshoots in temp.

    We have now reverted back to our old ways of switching it on when we need it. Kinda really regret buying tado now, really not a good system and not very smart! Might look to replace the system entirely if they can't get their act together and get this working. Scheduling to a fixed temp should be simple!! All their bragging about their algorithms that work magic all seems like lies now!
  • Wrote the solutiuon - I think the forum moves it up to the top of the thread

  • So the solution is tado have to do something their end?

    I also now have the same issue. I have a bunch of screenshots from multiple zones, multiple days where Tado is is "heating to" a temperature which is lower than the displayed current temperature and demanding heat from the boiler (a mixture of one and two bars on the little heat symbol).

    I've seen them explain that this is because the different parts of the system don't constantly transmit, but it is transmitting enough to display the current temperature has already been achieved, so why doesn't it then transmit to stop demanding heat!?

  • Yeah - not sure I beleive Tado if they say it's because "different system devices transmitting at different times"

    My system is:

    1 boiler

    1 tado thermostat

    NO smart radiator valves. - so the problem we see still occurrs with a one-thermostat system.


    Tado support might help you if you reach out to them via the support email

  • It almost feels like Tado Support are adjusting a Hysteresis setting for certain devices when someone actually reports this "heating to" misalignment problem.

    (Anyone else have this feeling)

    Before I fitted my Tado system to my Viessmann Combi Boiler with Wireless Controller......I was able to "set" the Hysteresis setting for my Wireless Controller/Thermostat.......it looks like I've "upgraded" to a "Smart" but slightly inferior controller/system.......Duhh !!.......isn't hindsight a wonderful thing 😎

  • I agree GrayDav - this sounds very likely.

    The Tado support person was so patronising - they said to remember that it was winter - so it is colder and that might be why my Tado system might be responding differently to how I remember.

    If they think their customers don't understand "seasons" I can't imagine they would expect we could understand PID control loops!

  • sdmaino
    sdmaino ✭✭✭

    Well, the point for me is that till last December, more or less, it worked perfectly, no hysteresis issues.

    I have this system from winter 2017.

    Now it often overheats. they changed something, 100% sure....

  • HotPotato
    HotPotato
    edited February 16

    I spoke too soon - this is not solved - my system is currently "heating to" a lower temperature than the actual temperature the thermostat is recording.... again... It's not as bad as it used to be since I got the "special" PID curve.


    sdmaino - you are not alone same experience here - the app is repeatably and observably failing basic maths.

    Tado support have told me they have changed nothing that would cause this.

    I mentioned to them that there were lots of people on here with the same problem.

    We must be all suffering from a mass-delusion :)

  • Same problem here. :( my bridge also stops pairing all the time. Anyone with that problem as well and has a solution?
  • I've also started seeing this problem since the past 2 weeks. Setup tado in February, and worked fine till mid-March.

    The bridge seems to keep losing connectivity and doesn't respond to changes either. I've made no changes in the setup or locations.

  • I have this problem too. If I combat the problem by lowering the temperature for that room or even the whole house, then eventually tado reports that it’s no longer heating. However, the boiler stays on.
    Had the system 2 years. It’s a new problem.
    Did anyone get a proper solution from tado?
    I have raised a support call and in the meantime have put my boiler on a timer to make sure it switches off at night.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!