Geofencing Control only working sporadically now

Hi

iPhone 11p recently updated to IOS15.

Within the last days I have started to enable heating again, as it is getting colder here. I have not added or deleted any time block. For each room I just pulled the temp slider to the button so it entered frost protection, and now I have just pressed the Resume Schedule button to enable heating again.

Geofence control only works sporadically. When I leave home in the morning it does not go to Away mode (and it is in Auto). Location setting is Always. App is allowed to run in the background. I only have one device which have location control enabled. Sometimes when I return home it switches briefly to Away mode, and few minutes later it switches to Home mode.

Switching manually between Home/Away works.

Any ideas?

br

Comments

  • Still not working reliably. Basically only switching mode when I open the app on my phone. Have tried with two different phones now, same issue. 3 weeks with different Tado supporters, and no progress! Not impressed.

  • rafm5
    rafm5 ✭✭✭

    @larsras Check your iOS privacy settings / reinstall the app if no success, so the phone will re-apply the correct privacy settings.


  • Have been through all that more than once with Tado support.

  • I'm having the same problem with Android 11, applies to both our phones.

    Graham

  • Settings home details confirm address on map
  • Hi
    Had a message from Tado today and they told me to upgrade to IOS 15.1 as this should solve Geofencing issues let’s wait and see
  • Well, I have been on IOS 15.1 since monday, and problem not solved. Contacted Tado yesterday, and response was that I yet another time should check my settings in the app, and the app permissions. They are still correct!

  • So Tado now claims that I have to leave the app open on the phone for this to work. In my 3 years of having this installation I have always closed the app when I didn't need to look at it, exactly as I do with other apps that I do no need, and which then continues to work even though they are not visible running.

    So a question here. Do you users in this forum need to have the app open for the geofence to work?

  • what_a_tado
    what_a_tado ✭✭
    edited October 28

    Hi @larsras, Personally, I have always left the app open as per the recommendations on the support pages.

    I have never had a problem with geofencing in the 3+ years I have had Tado, albeit I am an Android user as opposed to Apple.

  • IOS 15.1 has not solved this problem. Something has changed in the location or privacy settings in IOS 15 that Tado has failed to address properly.

    Leaving the app open in the background is just a workaround, not a solution. The Tado app is one of those apps you only rarely use because everything is supposed to be taken care of for you. That was the whole point, right?

    I expect Tado to come up with an explanation as to why background geofencing has stopped working in IOS 15 and an ETA for a fix.

  • larsras
    larsras
    edited November 8

    I gave up on this. Lousy support and the last supporter was directly rude to me. They totally ignored several times, that I have had an installation working for 3+ years, and suddenly Geofencing stops working unless I have the app open, and this is verified on two iPhones having iOS 15.1.

    So consequence is that at my next move I will tear down the tado installation here and not install it again.

  • rafm5
    rafm5 ✭✭✭
    edited November 8

    @larsras Just did a bit testing for you and based on:

    • iOS 15.2 (19C5026i)
    • location settings set to 'always'
    • background app refresh - on
    • precise location - on
    • low data mode - off
    • low power mode - off
    • home area - set

    I claim that it isn't possible to get Geofencing messages without the app running in the background. However it is not tado° but Apple.

    Going further, Apple changed things under the hood of region monitoring in iOS 15 and this mechanism stopped working reliably.

    @Rob please pick this up with your devs? They should be (if not already) feeding this back to Apple. Latest beta 15.2 doesn't resolve this issue yet (tested today)

    Also consider updating your FAQ

    I hope this helps.

  • ErBee
    ErBee
    edited November 9

    @larsras I hear you. Had a bit of a discussion with support myself and got a very unsatisfactory response. The "official" answer is that the Tado app will stop working when swiped close and that if I do not accept that I'll have to take it up with Apple (and stop bothering us).

    Duh.

    If they fail to fix this, they've lost me as a customer too...

  • @ErBee Exactly same response I got. It was not tados fault, but Apples, so I had to raise the issue my self towards Apple (as an End User)! As I have been doing customer support myself for a large international company for years, I took my time to tell him how proper customer support should be. Could be this made the case a bit more complicated.... ;-) btw. only 3 customers did suffer from this after iOS 15.1 update, and I guess we all 3 are here now.....

  • ErBee
    ErBee
    edited November 9

    @larsras Interesting. So either there's only 3 iOS users that upgraded to 15.1 (and they're all here) or, for all the other users that did upgrade to 15.1, there is no problem which implies that it can and should work as before while they also said that it can't work as before. Nice contradiction.

  • rafm5
    rafm5 ✭✭✭

    @ErBee It means that other users are not:

    a) bothered

    b) reporting it

    c) don't use geofencing

  • Hi guys, there are more of us but probably many didn't notice yet.

    Kinda frustrating that even when you pay for the subscription it won't react until you launch the app, so basically the same without a subscription.

    Was considering homekit integration and its geofencing. Did maybe any of you tried that before?

  • rafm5
    rafm5 ✭✭✭

    @isony11 Tado° is not the only manufacturer affected by this glitch. There is plenty of other unhappy users who are affected with same issue.

    If you interested in home automation I recommend looking at some Aqara products that will work well with Apple HomeKit. Tado° will work well with those too.

  • rafm5
    rafm5 ✭✭✭

    Hi All,

    I was able to get Geofencing working correctly today and with tado° app not running in the background.

    Anyone with access to iOS developer beta 15.2 beta 3? Can you also test and confirm?


  • Having the same issues. Started with Tado a few weeks ago when all our family iPhones (2 iPhone 12, iPhone Xr and iPhone SE 2021) were on iOS14 and all has been working fine, including location services with automatic home/away modes. I am sure about that because push notifications came in reliably on all our Apple watches.

    Updating all the devices to iOS15 broke all 3rd party location services completely. Tado home/away no longer functional, Nuki smart lock (unlock function when approaching home/door) was dead. Happened on all 4 devices, so seems to be not a single problem. All app updates since then could not bring back functionality, sometimes the location services do work when the apps running in the background. But it is still far from reliable.

  • rafm5
    rafm5 ✭✭✭

    @christianj Report to Apple. So far the fix applied to iOS 15.2 beta 3 works.

  • @rafm5 already did that. Plus Tado app update 6.27 released today... crossing my fingers.

  • I have the same issue. I’ve checked all iPhone settings as per tado recommendations. No change to the erratic behaviour of the tado device. I’ve searched online and see some people have blamed iOS 15.1

    I sought assistance from tado - response; check settings and get back to us if that doesn’t work. I’d already done that - and deleted it and re-installed etc.

    Going to use an android phone instead for a bit (do my own research!) to see if that’s better.

  • When I used the apple gadgets to try and read these related discussions, I was unable to see all the additions - just the 1st opening lines. I also had to start a new password while in the tado 'world'. Now I'm on the android phone, all the discussions are now visible and I was able to log in with my original password. Weird. User error or apple issues...?
  • I am experiencing this issue with all my geofencing apps (Locative, Geofency, IFTTT app and, of course, Tado) both with my iPhone 13 Pro and my wife’s iPhone 13 Pro Max.

    It used to work fine with our previous iPhone 12 Pro / Pro Max models. It is very frustrating, but it is clearly related to iOS 15.

  • Same issue here. Very frustrating! Especially with two teenage daughters that I have remind constantly that they have to keep the app open. They constantly forget so the geofencing feature is. It working as it should. The main reason I switched to tado was to make use of the geofencing feature. All of us have very irregular schedules so the normal fixed smart schedule in the app is not working for us. I hope this can be fixed soon.
  • rafm5
    rafm5 ✭✭✭

    To all impacted by the Geofencing issue. Have you reported it to Apple?

  • @rafm5 Yes, did report that issue. Anyhow, web is full of such reports and Apple is aware of it. See here Nuki Smartlock, which relies heavily on geofencing for their auto-unlock feature:

    https://nuki.io/en/blog/nuki-news/ios-15-update-effects-on-the-nuki-app-and-auto-unlock/
  • rafm5
    rafm5 ✭✭✭

    @christianj Geofencing works well on iOS 15.2 beta. GM version should be released to public shortly.